summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Lee2016-02-25 12:12:01 -0800
committerAntony Lee2016-02-25 12:12:01 -0800
commitacbae9ca2c13b0de8c0563d531c3688dc48a72a3 (patch)
treea35cee4f0a823be716397c8c1bb3e66e9c72ae04
downloadaur-acbae9ca2c13b0de8c0563d531c3688dc48a72a3.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f5802bf1d1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Feb 25 20:11:16 UTC 2016
+pkgbase = python-scikit-sparse
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/scikit-sparse/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python-scipy
+ depends = suitesparse
+ source = https://pypi.python.org/packages/source/s/scikit-sparse/scikit-sparse-0.3.tar.gz
+ md5sums = edd0f3eaed471fe53ca4b0c03acc4ab3
+
+pkgname = python-scikit-sparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d741d805b9d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+
+_pyname=scikit-sparse
+pkgname=python-$_pyname
+pkgver=0.3
+pkgrel=1
+pkgdesc=
+url="https://pypi.python.org/pypi/$_pyname/"
+depends=('python-scipy' 'suitesparse')
+license=('GPL')
+arch=('i686' 'x86_64')
+source=("https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz")
+md5sums=('edd0f3eaed471fe53ca4b0c03acc4ab3')
+
+build() {
+ cd $srcdir/$_pyname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pyname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}