summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2020-01-11 13:31:06 +0100
committerGordian Edenhofer2020-01-11 13:33:59 +0100
commit82fafc68475c26512137c24511b3b226d4fc989a (patch)
tree530af27fb41b0462ec64b46060a25e72c516c6e8
parent48446a34305c3d933d6fee0c80f8118a651a3cd8 (diff)
downloadaur-82fafc68475c26512137c24511b3b226d4fc989a.tar.gz
Prune python2 versions of packages due to EOL
Drop python2-nautilus. upgpkg: bcc 0.12.0-1 upgpkg: python-gensim 3.8.1-1 upgpkg: python-scikit-surprise 1.1.0-2 upgpkg: python-scikit-surprise-git 1.0.4.r112.gef3ed6e-1 upgpkg: python-smart_open 1.9.0-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41e15bdb6376..284c49a77954 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,11 +7,6 @@ pkgbase = python-scikit-surprise
license = BSD-3-Clause
makedepends = python-setuptools
makedepends = cython
- makedepends = python-numpy
- source = python-scikit-surprise-1.1.0.tar.gz::https://github.com/NicolasHug/Surprise/archive/v1.1.0.tar.gz
- sha512sums = d8f28786029079ac9db52c61c4b5bf30150da96718e292cad90bb58f7d25173391e8686808d3b4e746987059057d21943570ed4be2ad8a1c3e8046e764b93600
-
-pkgname = python-scikit-surprise
depends = python-joblib
depends = python-numpy
depends = python-scipy
@@ -22,3 +17,7 @@ pkgname = python-scikit-surprise
optdepends = python-sphinx: documentation generator
optdepends = python-sphinx_rtd_theme: Read The Docs theme for documentation generator
optdepends = python-sphinxcontrib-spelling: spelling extension for documentation generator
+ source = python-scikit-surprise-1.1.0.tar.gz::https://github.com/NicolasHug/Surprise/archive/v1.1.0.tar.gz
+ sha512sums = d8f28786029079ac9db52c61c4b5bf30150da96718e292cad90bb58f7d25173391e8686808d3b4e746987059057d21943570ed4be2ad8a1c3e8046e764b93600
+
+pkgname = python-scikit-surprise
diff --git a/PKGBUILD b/PKGBUILD
index 87f9f40bd6dc..e0f67c8d88e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,14 @@ pkgdesc="Python scikit for building and analyzing recommender systems"
arch=('any')
license=('BSD-3-Clause')
url="https://github.com/NicolasHug/${_reponame}"
-depends=()
-makedepends=('python-setuptools' 'cython' 'python-numpy')
+depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
+optdepends=("flake8: code linting to comply with contributing standards"
+ "python-pandas: dataframe handling"
+ "python-pytest: test suite"
+ "python-sphinx: documentation generator"
+ "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
+ "python-sphinxcontrib-spelling: spelling extension for documentation generator")
+makedepends=('python-setuptools' 'cython')
provides=()
conflicts=()
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/NicolasHug/${_reponame}/archive/v${pkgver}.tar.gz")
@@ -23,14 +29,6 @@ build() {
}
package() {
- depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
- optdepends=("flake8: code linting to comply with contributing standards"
- "python-pandas: dataframe handling"
- "python-pytest: test suite"
- "python-sphinx: documentation generator"
- "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
- "python-sphinxcontrib-spelling: spelling extension for documentation generator")
-
cd "${srcdir}/${_reponame}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
ln -s surprise "${pkgdir}/usr/bin/surprise3"