summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-10-02 12:44:09 +0900
committerGordian Edenhofer2018-10-02 12:57:53 +0900
commitbe4827d0d45890a8f529c2c199300c8c3a50649f (patch)
treed6a20b6d8a3a24d46eaae40b63764517a207be51
parentbdf444b86eec252dfbbbf78fb6df9c8167385bb6 (diff)
downloadaur-be4827d0d45890a8f529c2c199300c8c3a50649f.tar.gz
upgpkg: python-scikit-surprise 1.0.6-2
Merge build_* functions as there only ever should exist one 'build()'. Clean up makedepends and fix a link in /usr/bin. upgpkg: python-scikit-surprise-git 1.0.4.r73.g633ab47-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 7 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64f6261139b8..9f7611a4ab73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = python-scikit-surprise
pkgdesc = Python scikit for building and analyzing recommender systems
pkgver = 1.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/NicolasHug/Surprise
arch = any
license = BSD-3-Clause
- makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
makedepends = cython
@@ -26,8 +25,6 @@ pkgname = python-scikit-surprise
optdepends = python-sphinx: documentation generator
optdepends = python-sphinx_rtd_theme: Read The Docs theme for documentation generator
optdepends = python-sphinxcontrib-spelling: spelling extension for documentation generator
- provides = python-scikit-surprise=1.0.6
- conflicts = python-scikit-surprise
pkgname = python2-scikit-surprise
depends = python2-joblib
@@ -40,5 +37,3 @@ pkgname = python2-scikit-surprise
optdepends = python2-sphinx: documentation generator
optdepends = python2-sphinx_rtd_theme: Read The Docs theme for documentation generator
optdepends = python2-sphinxcontrib-spelling: spelling extension for documentation generator
- provides = python2-scikit-surprise=1.0.6
- conflicts = python2-scikit-surprise
diff --git a/PKGBUILD b/PKGBUILD
index 99f5f1460cd1..ca710b1b14e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ pkgbase=python-scikit-surprise
pkgname=("python-scikit-surprise" "python2-scikit-surprise")
_reponame="Surprise"
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Python scikit for building and analyzing recommender systems"
arch=('any')
license=('BSD-3-Clause')
url="https://github.com/NicolasHug/${_reponame}"
depends=('')
-makedepends=('git' 'python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'python-numpy' 'python2-numpy')
+makedepends=('python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'python-numpy' 'python2-numpy')
provides=("")
conflicts=("")
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/NicolasHug/${_reponame}/archive/v${pkgver}.tar.gz")
@@ -20,14 +20,12 @@ prepare() {
cp -a "${srcdir}/${_reponame}-${pkgver}"{,-py2}
}
-build_python-scikit-surprise() {
+build() {
cd "${srcdir}/${_reponame}-${pkgver}"
python setup.py clean
rm -rf build dist
python setup.py build
-}
-build_python2-scikit-surprise() {
cd "${srcdir}/${_reponame}-${pkgver}-py2"
python2 setup.py clean
rm -rf build dist
@@ -42,14 +40,12 @@ package_python-scikit-surprise() {
"python-sphinx: documentation generator"
"python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
"python-sphinxcontrib-spelling: spelling extension for documentation generator")
- provides=("python-scikit-surprise=${pkgver}")
- conflicts=("python-scikit-surprise")
cd "${srcdir}/${_reponame}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
- ln -s "${pkgdir}/usr/bin/surprise"{,3}
+ ln -s surprise "${pkgdir}/usr/bin/surprise3"
- install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname///}/LICENSE"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_python2-scikit-surprise() {
@@ -60,12 +56,10 @@ package_python2-scikit-surprise() {
"python2-sphinx: documentation generator"
"python2-sphinx_rtd_theme: Read The Docs theme for documentation generator"
"python2-sphinxcontrib-spelling: spelling extension for documentation generator")
- provides=("python2-scikit-surprise=${pkgver}")
- conflicts=("python2-scikit-surprise")
cd "${srcdir}/${_reponame}-${pkgver}-py2"
python2 setup.py install --root="${pkgdir}" --optimize=1
mv "${pkgdir}/usr/bin/surprise"{,2}
- install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname///}/LICENSE"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}