summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-10-02 12:44:09 +0900
committerGordian Edenhofer2018-10-02 12:57:53 +0900
commit1d9ea0779dee65c364712c3e2f6004636e950d49 (patch)
treed3226705a5a5d8f7aae93913697f275d84853686
parent92f0bb6d87c4e32eec6b522c89f7ba092cc1d3f5 (diff)
downloadaur-1d9ea0779dee65c364712c3e2f6004636e950d49.tar.gz
upgpkg: python-scikit-surprise 1.0.6-2
Merge build_* functions as there only ever should exist one 'build()'. Clean up makedepends and fix a link in /usr/bin. upgpkg: python-scikit-surprise-git 1.0.4.r73.g633ab47-1
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdaa3b573e0e..7c2b5018911e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,14 +28,12 @@ prepare() {
cp -a "${srcdir}/${_reponame}"{,-py2}
}
-build_python-scikit-surprise-git() {
+build() {
cd "${srcdir}/${_reponame}"
python setup.py clean
rm -rf build dist
python setup.py build
-}
-build_python2-scikit-surprise-git() {
cd "${srcdir}/${_reponame}-py2"
python2 setup.py clean
rm -rf build dist
@@ -55,7 +53,7 @@ package_python-scikit-surprise-git() {
cd "${srcdir}/${_reponame}"
python setup.py install --root="${pkgdir}" --optimize=1
- ln -s "${pkgdir}/usr/bin/surprise"{,3}
+ ln -s surprise "${pkgdir}/usr/bin/surprise3"
install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname/-git//}/LICENSE"
}