summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-08-01 18:24:17 +0900
committerGordian Edenhofer2018-08-01 18:25:50 +0900
commit92f0bb6d87c4e32eec6b522c89f7ba092cc1d3f5 (patch)
treeb879641c89af59baf9b407cd968b00b11a33d7a1
downloadaur-92f0bb6d87c4e32eec6b522c89f7ba092cc1d3f5.tar.gz
addpkg: python-scikit-surprise 1.0.6-1
addpkg: python-scikit-surprise-git 1.0.4.r73.g633ab47-1
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD79
2 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e37ceffb38fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = python-scikit-surprise-git
+ pkgdesc = Python scikit for building and analyzing recommender systems
+ pkgver = 1.0.4.r73.g633ab47
+ pkgrel = 1
+ url = https://github.com/NicolasHug/Surprise
+ arch = any
+ license = BSD-3-Clause
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = cython
+ makedepends = cython2
+ makedepends = python-numpy
+ makedepends = python2-numpy
+ source = git+https://github.com/NicolasHug/Surprise
+ sha512sums = SKIP
+
+pkgname = python-scikit-surprise-git
+ depends = python-joblib
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-six
+ optdepends = flake8: code linting to comply with contributing standards
+ optdepends = python-pandas: dataframe handling
+ optdepends = python-pytest: test suite
+ optdepends = python-sphinx: documentation generator
+ optdepends = python-sphinx_rtd_theme: Read The Docs theme for documentation generator
+ optdepends = python-sphinxcontrib-spelling: spelling extension for documentation generator
+ provides = python-scikit-surprise=1.0.4.r73.g633ab47
+ conflicts = python-scikit-surprise
+
+pkgname = python2-scikit-surprise-git
+ depends = python2-joblib
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-six
+ optdepends = python2-flake8: code linting to comply with contributing standards
+ optdepends = python2-pandas: dataframe handling
+ optdepends = python2-pytest: test suite
+ optdepends = python2-sphinx: documentation generator
+ optdepends = python2-sphinx_rtd_theme: Read The Docs theme for documentation generator
+ optdepends = python2-sphinxcontrib-spelling: spelling extension for documentation generator
+ provides = python2-scikit-surprise=1.0.4.r73.g633ab47
+ conflicts = python2-scikit-surprise
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdaa3b573e0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer@gmail.com>
+
+pkgbase=python-scikit-surprise-git
+pkgname=("python-scikit-surprise-git" "python2-scikit-surprise-git")
+_reponame="Surprise"
+pkgver=1.0.4.r73.g633ab47
+pkgrel=1
+pkgdesc="Python scikit for building and analyzing recommender systems"
+arch=('any')
+license=('BSD-3-Clause')
+url="https://github.com/NicolasHug/${_reponame}"
+depends=('')
+makedepends=('git' 'python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'python-numpy' 'python2-numpy')
+provides=("")
+conflicts=("")
+source=("git+https://github.com/NicolasHug/${_reponame}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' \
+ || printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cp -a "${srcdir}/${_reponame}"{,-py2}
+}
+
+build_python-scikit-surprise-git() {
+ cd "${srcdir}/${_reponame}"
+ python setup.py clean
+ rm -rf build dist
+ python setup.py build
+}
+
+build_python2-scikit-surprise-git() {
+ cd "${srcdir}/${_reponame}-py2"
+ python2 setup.py clean
+ rm -rf build dist
+ python2 setup.py build
+}
+
+package_python-scikit-surprise-git() {
+ depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
+ optdepends=("flake8: code linting to comply with contributing standards"
+ "python-pandas: dataframe handling"
+ "python-pytest: test suite"
+ "python-sphinx: documentation generator"
+ "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
+ "python-sphinxcontrib-spelling: spelling extension for documentation generator")
+ provides=("python-scikit-surprise=${pkgver}")
+ conflicts=("python-scikit-surprise")
+
+ cd "${srcdir}/${_reponame}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ ln -s "${pkgdir}/usr/bin/surprise"{,3}
+
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname/-git//}/LICENSE"
+}
+
+package_python2-scikit-surprise-git() {
+ depends=('python2-joblib' 'python2-numpy' 'python2-scipy' 'python2-six')
+ optdepends=("python2-flake8: code linting to comply with contributing standards"
+ "python2-pandas: dataframe handling"
+ "python2-pytest: test suite"
+ "python2-sphinx: documentation generator"
+ "python2-sphinx_rtd_theme: Read The Docs theme for documentation generator"
+ "python2-sphinxcontrib-spelling: spelling extension for documentation generator")
+ provides=("python2-scikit-surprise=${pkgver}")
+ conflicts=("python2-scikit-surprise")
+
+ cd "${srcdir}/${_reponame}-py2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ mv "${pkgdir}/usr/bin/surprise"{,2}
+
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname/-git//}/LICENSE"
+}