summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2019-02-11 18:14:36 +0800
committerJingbei Li2019-02-11 18:14:36 +0800
commit530f2fd35438c498b0a79aceb7f02fd997af0eb7 (patch)
treec10312c194aa8588971f000fecfd453c4e18c96d
parent2a5238fc38cbcd4cd4a1b87ab2f83e97985c598b (diff)
downloadaur-530f2fd35438c498b0a79aceb7f02fd997af0eb7.tar.gz
upgraded to 1.2.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 9 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 426c95d736ec..46eb5145097b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-scipy-mkl
pkgdesc = SciPy is open-source software for mathematics, science, and engineering.
- pkgver = 1.2.0
+ pkgver = 1.2.1
pkgrel = 1
url = http://www.scipy.org/
arch = i686
@@ -8,22 +8,18 @@ pkgbase = python-scipy-mkl
license = BSD
checkdepends = python-pytest
checkdepends = python2-pytest
- makedepends = gcc-fortran
makedepends = python-numpy
makedepends = python2-numpy
makedepends = python-setuptools
makedepends = python2-setuptools
- makedepends = intel-compiler-base
- makedepends = intel-fortran-compiler
- makedepends = intel-mkl
depends = intel-compiler-base
depends = intel-fortran-compiler
depends = intel-mkl
- source = https://github.com/scipy/scipy/releases/download/v1.2.0/scipy-1.2.0.tar.gz
+ source = https://github.com/scipy/scipy/releases/download/v1.2.1/scipy-1.2.1.tar.gz
source = build_python.sh
source = fix-utf8.patch
- sha256sums = 51a2424c8ed80e60bdb9a896806e7adaf24a58253b326fbad10f80a6d06f2214
- sha256sums = 541bade4ce71fc139594a7e025923916ec37a7fdbf5e4aec4b86abedf439395c
+ sha256sums = e085d1babcb419bbe58e2e805ac61924dac4ca45a07c9fa081144739e500aa3c
+ sha256sums = 4970774d5c0b43c48634b01c1eabf7604dc3c98177fb5fed5585dc5be71183b4
sha256sums = 8095c3ed80658019f8976ff7e298ac80939b3c2814dfdd372d63c04a285d419e
pkgname = python-scipy-mkl
diff --git a/PKGBUILD b/PKGBUILD
index 25b46627e3f4..ad938d0c327c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,21 @@
pkgbase='python-scipy-mkl'
pkgname=('python-scipy-mkl' 'python2-scipy-mkl')
-pkgver=1.2.0
+pkgver=1.2.1
pkgrel=1
pkgdesc="SciPy is open-source software for mathematics, science, and engineering."
arch=('i686' 'x86_64')
url="http://www.scipy.org/"
license=('BSD')
depends=('intel-compiler-base' 'intel-fortran-compiler' 'intel-mkl')
-makedepends=('gcc-fortran' 'python-numpy' 'python2-numpy' 'python-setuptools' 'python2-setuptools' 'intel-compiler-base' 'intel-fortran-compiler' 'intel-mkl')
+makedepends=('python-numpy' 'python2-numpy' 'python-setuptools' 'python2-setuptools')
checkdepends=('python-pytest' 'python2-pytest')
source=(
"https://github.com/scipy/scipy/releases/download/v${pkgver}/scipy-${pkgver}.tar.gz"
"build_python.sh"
'fix-utf8.patch'
)
-sha256sums=('51a2424c8ed80e60bdb9a896806e7adaf24a58253b326fbad10f80a6d06f2214'
+sha256sums=('e085d1babcb419bbe58e2e805ac61924dac4ca45a07c9fa081144739e500aa3c'
'4970774d5c0b43c48634b01c1eabf7604dc3c98177fb5fed5585dc5be71183b4'
'8095c3ed80658019f8976ff7e298ac80939b3c2814dfdd372d63c04a285d419e')
@@ -43,18 +43,7 @@ prepare() {
}
build() {
- # glibc 2.18 compatibility issue
- # cp /opt/intel/compilers_and_libraries_*/linux/compiler/include/math.h .
- # sed \
- # -e '173s/.*/# include "\/usr\/include\/math.h"/' \
- # -e '1218s/!//' \
- # -i math.h
- # export __INTEL_PRE_CFLAGS="-I$srcdir "
-
export LDFLAGS="-Wall -shared"
- export use_intel_cc=true
- export use_gcc=false
-
# build for python3
cd scipy-${pkgver}
@@ -65,7 +54,6 @@ build() {
cd ../scipy-${pkgver}-py2
python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
#sh build_python.sh python2
-
}
#check() {
@@ -99,8 +87,7 @@ package_python-scipy-mkl() {
python3 setup.py config --compiler=intelem --fcompiler=intelem install --prefix=/usr --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE.txt \
- "${pkgdir}/usr/share/licenses/python-scipy/LICENSE"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-scipy/LICENSE"
}
package_python2-scipy-mkl() {
@@ -114,6 +101,5 @@ package_python2-scipy-mkl() {
python2 setup.py config --compiler=intelem --fcompiler=intelem install --prefix=/usr --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE.txt \
- "${pkgdir}/usr/share/licenses/python2-scipy/LICENSE"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-scipy/LICENSE"
}