summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2019-11-18 11:40:50 -0500
committerchrisjbillington2019-11-18 11:40:50 -0500
commit9ddd25770a7a66e49d9d5709f76013e1fd77b673 (patch)
tree406243b3f9c0fbd49560cfa32536533d986f989d
downloadaur-9ddd25770a7a66e49d9d5709f76013e1fd77b673.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b565d29f71a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-scipy-mkl-bin
+ pkgdesc = SciPy is open-source software for mathematics, science, and engineering - with Intel MKL - prebuilt binaries from Anaconda
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://www.scipy.org/
+ arch = x86_64
+ license = custom
+ depends = python-numpy
+ depends = python-mkl-service
+ optdepends = python-pillow: for image saving module
+ provides = python-scipy
+ provides = python-scipy-mkl
+ conflicts = python-scipy
+ source = https://repo.continuum.io/pkgs/main/linux-64/scipy-1.3.1-py38h7c811a0_0.tar.bz2
+ source = https://repo.continuum.io/pkgs/main/linux-64/libgfortran-ng-7.3.0-hdf63c60_0.tar.bz2
+ sha256sums = 2787a141b1b962cae3f580d492e7ab38d359f795674346ee6fa5d4dc3712ca42
+ sha256sums = 83c6fdb30a240fbaa09f5d2e2ae8f092759cb710bc3fa628ccb18934fc237b7f
+
+pkgname = python-scipy-mkl-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1a707fa1ad4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer : Chris Billington <chrisjbillington@gmail.com>
+pkgname=python-scipy-mkl-bin
+_pkgname=scipy
+pkgver=1.3.1
+_build=py38h7c811a0_0
+pkgrel=1
+_libgfortran=libgfortran-ng-7.3.0-hdf63c60_0
+pkgdesc="SciPy is open-source software for mathematics, science, and engineering - with Intel MKL - prebuilt binaries from Anaconda"
+arch=('x86_64')
+url="http://www.scipy.org/"
+license=('custom')
+provides=('python-scipy' 'python-scipy-mkl')
+conflicts=('python-scipy')
+depends=('python-numpy' 'python-mkl-service')
+# Note: This package by default bundles libgfortran 7 from anaconda, because compiling
+# gcc7-libs takes hours. If you already have gcc7-libs or prefer to compile it yourself
+# then set USE_GCC7LIBS=1 before running makepkg.
+if [ "$USE_GCC7LIBS" ]; then
+ echo "Using gcc7-libs instead of bundling gfortran 7"
+ depends+=('gcc7-libs')
+else:
+ echo "Bundling precompiled libgfortran from Anaconda"
+ conflicts+=('gcc7-libs')
+fi
+optdepends=('python-pillow: for image saving module')
+source=("https://repo.continuum.io/pkgs/main/linux-64/${_pkgname}-${pkgver}-${_build}.tar.bz2"
+ "https://repo.continuum.io/pkgs/main/linux-64/${_libgfortran}.tar.bz2"
+ )
+sha256sums=('2787a141b1b962cae3f580d492e7ab38d359f795674346ee6fa5d4dc3712ca42'
+ '83c6fdb30a240fbaa09f5d2e2ae8f092759cb710bc3fa628ccb18934fc237b7f')
+
+package() {
+ mkdir -p "${pkgdir}/usr/"
+ if [ "$USE_GCC7LIBS" ]; then
+ # Just the Python modules:
+ PYTHONMINOR=$(python -c 'import sys; print(sys.version_info.minor)')
+ PYTHONXY="python3.${PYTHONMINOR}"
+ mkdir -p "${pkgdir}/usr/lib"
+ cp -drp --no-preserve=ownership "${srcdir}/lib/${PYTHONXY}" "${pkgdir}/usr/lib"
+ else
+ # The whole /lib tree, including python modules and libgfortran
+ cp -drp --no-preserve=ownership "${srcdir}/lib" "${pkgdir}/usr/lib"
+ # Do not install as default libgfortran - delete link to libgfortran.so.4:
+ rm "${pkgdir}/usr/lib/libgfortran.so"
+ # libgfortran license
+ GFORTRAN_LICENSE="/share/licenses/libgfortran/RUNTIME.LIBRARY.EXCEPTION"
+ install -D -m 644 "${srcdir}/${GFORTRAN_LICENSE}" "${pkgdir}/usr/${GFORTRAN_LICENSE}"
+ fi
+ install -D -m 644 "${srcdir}/info/licenses/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}