summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-06-23 23:31:55 -0400
committerGuillaume Horel2020-06-23 23:31:55 -0400
commit84c1824482a4400940cf4cdaf1750b72528cf32a (patch)
treeb2ecd05b3e6afbbdb5b935b7023785668ee4c409
parent2756e219796c032f80aeac6f1e1260e98ee39517 (diff)
downloadaur-python-scipy-openblas.tar.gz
version bump
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bb620b86b6b..5e7c3b78e906 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = python-scipy-openblas
pkgdesc = SciPy is open-source software for mathematics, science, and engineering.
- pkgver = 1.4.1
- pkgrel = 2
+ pkgver = 1.5.0
+ pkgrel = 1
url = http://www.scipy.org/
- arch = i686
arch = x86_64
license = BSD
checkdepends = python-pytest
@@ -12,14 +11,11 @@ pkgbase = python-scipy-openblas
makedepends = python-setuptools
makedepends = openblas-lapack
makedepends = pybind11
- source = https://github.com/scipy/scipy/releases/download/v1.4.1/scipy-1.4.1.tar.gz
- sha512sums = 79407a2cbb4ba29c0941570181df4d7835e5791e50a3abef9b63c2fc5b15308a2e4964eb71cdebbee8cd2dcb8e497cf92fe50ee21fb12cac3013ea5e0466b25d
-
-pkgname = python-scipy-openblas
- depends = python-numpy-openblas
- depends = openblas-lapack
optdepends = python-pillow: for image saving module
- provides = python3-scipy
- provides = python-scipy
+ provides = python-scipy=1.5.0
conflicts = python-scipy
+ source = https://github.com/scipy/scipy/releases/download/v1.5.0/scipy-1.5.0.tar.gz
+ sha512sums = 4c981a3125a88593cbc5a17417022a5db8f6ccb4c1c24e78afeb9bb26428b81d2d0fe9965caa418753b1bbbda2fa30533fa1307aac6ab168458d68f7b46049be
+
+pkgname = python-scipy-openblas
diff --git a/PKGBUILD b/PKGBUILD
index a5af84d33185..976e81d7ed33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: thasibule <guillaume.horel@gmail.com>
# Contributor: ptrr <piksarv .at. gmail.com>
# Contributor: lobisquit <enricolovisotto@gmail.com>
# Contributor: chmgtr1 <chmgtr1@gmail.com>
@@ -9,16 +10,19 @@
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
pkgname="python-scipy-openblas"
-pkgver=1.4.1
-pkgrel=2
+pkgver=1.5.0
+pkgrel=1
pkgdesc="SciPy is open-source software for mathematics, science, and engineering."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.scipy.org/"
license=('BSD')
makedepends=('gcc-fortran' 'python-numpy-openblas' 'python-setuptools' 'openblas-lapack' 'pybind11')
checkdepends=('python-pytest')
+optdepends=('python-pillow: for image saving module')
+provides=("python-scipy=$pkgver")
+conflicts=('python-scipy')
source=("https://github.com/scipy/scipy/releases/download/v${pkgver}/scipy-${pkgver}.tar.gz")
-sha512sums=('79407a2cbb4ba29c0941570181df4d7835e5791e50a3abef9b63c2fc5b15308a2e4964eb71cdebbee8cd2dcb8e497cf92fe50ee21fb12cac3013ea5e0466b25d')
+sha512sums=('4c981a3125a88593cbc5a17417022a5db8f6ccb4c1c24e78afeb9bb26428b81d2d0fe9965caa418753b1bbbda2fa30533fa1307aac6ab168458d68f7b46049be')
build() {
@@ -49,11 +53,7 @@ check() {
python -c "from scipy import test; test('full')"
}
-package_python-scipy-openblas() {
- depends=('python-numpy-openblas' 'openblas-lapack')
- provides=('python3-scipy' 'python-scipy')
- optdepends=('python-pillow: for image saving module')
- conflicts=('python-scipy')
+package() {
cd scipy-${pkgver}
export Atlas=None