summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-07-17 19:24:32 -0500
committerCarlos Aznarán Laos2021-07-17 19:24:32 -0500
commit4062dedf45b0a38547f32eef1ca318ec20bc0bc7 (patch)
treeb37e00f1f8ddaca17382530f9cfd3578bca7dc2d
parent7bc000a7ce3164f28edcdba82ac4fac17477c6e4 (diff)
downloadaur-4062dedf45b0a38547f32eef1ca318ec20bc0bc7.tar.gz
Remove __pycache__ folder
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ecdfe6f12b7..03087499c262 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-scipyx
pkgdesc = SciPy fixes and extensions
pkgver = 0.0.15
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/nschloe/scipyx
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 4094c1a4aad1..386c0840fd9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _base=scipyx
pkgname=python-${_base}
pkgdesc="SciPy fixes and extensions"
pkgver=0.0.15
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/nschloe/${_base}"
license=(BSD)
@@ -27,5 +27,6 @@ package() {
cd "${_base}-${pkgver}"
export PYTHONHASHSEED=0
python -c "from setuptools import setup; setup();" install --root="${pkgdir}" --optimize=1
+ rm -r "${pkgdir}$(python -c "import site; print(site.getsitepackages()[0])")/${_base}/__pycache__"
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}