summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-09 10:59:58 -0500
committerCarlos Aznarán Laos2022-03-09 10:59:58 -0500
commitd921d07c1179aa9c891be2b6c6e0ce833fef0d52 (patch)
treea0763a3132bf6b9eae36183ed1cf54001c2ef436
parent1dd6e2831ab0a5ae85ac98f9add06c0da775d4eb (diff)
downloadaur-python-sciscipy.tar.gz
Drop python2
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD58
-rw-r--r--fixlib.diff13
4 files changed, 19 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d43f8f641cb0..3efe5095485b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,14 @@
-# Generated by mksrcinfo v8
-# Wed Apr 12 19:38:09 UTC 2017
pkgbase = python-sciscipy
pkgdesc = A Scilab API for Python
pkgver = 1.0.1
pkgrel = 1
- url = http://forge.scilab.org/index.php/p/sciscipy/
+ url = http://forge.scilab.org/index.php/p/sciscipy
arch = any
license = GPL
makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = scilab
- source = http://forge.scilab.org/index.php/p/sciscipy/downloads/get/sciscipy-1.0.1.tar.gz
- source = fixlib.diff
- md5sums = 80fa3e4dbd85445c2535e173c24ffc77
- md5sums = SKIP
-
-pkgname = python-sciscipy
depends = python-numpy
depends = scilab
- conflicts = python2-sciscipy
-
-pkgname = python2-sciscipy
- depends = python2-numpy
- depends = scilab
- conflicts = python-sciscipy
+ source = http://forge.scilab.org/index.php/p/sciscipy/downloads/get/sciscipy-1.0.1.tar.gz
+ sha512sums = 2aef9505ae61182e349a2d97cc6efc83e5ab3735f66d9084f2861cd0ff19a82d86d729ec8c9b6dcafc8518c91ef26ce3ffc7decac7064fe4b10ea9e761a231e6
+pkgname = python-sciscipy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 5d409cfd07f8..caea9e07f7dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,25 @@
-pkgbase=('python-sciscipy')
-pkgname=('python-sciscipy' 'python2-sciscipy')
+# Contributor: Michel Zou <xantares09@hotmail.com>
+_base=sciscipy
+pkgname=python-${_base}
pkgver=1.0.1
pkgrel=1
pkgdesc="A Scilab API for Python"
-arch=('any')
-url="http://forge.scilab.org/index.php/p/sciscipy/"
-license=('GPL')
-source=("http://forge.scilab.org/index.php/p/sciscipy/downloads/get/sciscipy-${pkgver}.tar.gz"
- "fixlib.diff")
-md5sums=('80fa3e4dbd85445c2535e173c24ffc77'
- 'SKIP')
-makedepends=('python-setuptools' 'python2-setuptools' 'scilab')
-
-prepare() {
- cd "$srcdir/sciscipy-$pkgver"
- patch -p1 -i "$srcdir/fixlib.diff"
- /usr/lib/python2.7/Tools/scripts/reindent.py setup.py
- 2to3 -w setup.py scilab.py
-
- cp -r "$srcdir/sciscipy-$pkgver" "$srcdir/sciscipy-$pkgver-py2"
-
- sed -i "s|PyString_|PyBytes_|g" sciconv_write.c
- sed -i "s|PyInt_|PyLong_|g" sciconv_write.c
-}
+arch=(any)
+url="http://forge.scilab.org/index.php/p/${_base}"
+license=(GPL)
+depends=(python-numpy scilab)
+makedepends=(python-setuptools)
+source=(${url}/downloads/get/${_base}-${pkgver}.tar.gz)
+sha512sums=('2aef9505ae61182e349a2d97cc6efc83e5ab3735f66d9084f2861cd0ff19a82d86d729ec8c9b6dcafc8518c91ef26ce3ffc7decac7064fe4b10ea9e761a231e6')
build() {
- cd "$srcdir/sciscipy-$pkgver-py2"
- python2 setup.py build
- cd "$srcdir/sciscipy-$pkgver"
+ cd ${_base}-${pkgver}
python setup.py build
}
-check () {
- cd "$srcdir/sciscipy-$pkgver"
-# python2 setup.py test
-}
-
-package_python2-sciscipy() {
- depends=('python2-numpy' 'scilab')
- conflicts=('python-sciscipy')
-
- cd "$srcdir/sciscipy-$pkgver-py2"
- python2 ./setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-package_python-sciscipy() {
- depends=('python-numpy' 'scilab')
- conflicts=('python2-sciscipy')
-
- cd "$srcdir/sciscipy-$pkgver"
- python ./setup.py install --prefix=/usr --root="$pkgdir"
+package() {
+ cd ${_base}-${pkgver}
+ python setup.py install --prefix=/usr --root="$pkgdir"
}
# test:
diff --git a/fixlib.diff b/fixlib.diff
deleted file mode 100644
index cd2bdc016e05..000000000000
--- a/fixlib.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-Only in sciscipy-1.0.1.orig: build
-diff -ur sciscipy-1.0.1/setup.py sciscipy-1.0.1.orig/setup.py
---- sciscipy-1.0.1/setup.py 2013-09-07 20:47:53.000000000 +0000
-+++ sciscipy-1.0.1.orig/setup.py 2014-02-06 15:10:43.616721604 +0000
-@@ -27,7 +27,7 @@
- ]
- sci_lib_dir = [os.path.join("/","usr", "lib", "scilab")]
- sci_librairies = []
-- sci_extra_link_args = ['-Wl,--no-as-needed', '-lscilab', '-lsciapi_scilab', '-lscicall_scilab', '-lscioutput_stream', '-lscicore', '-lscilinear_algebra', '-lsciconsole', '-lscilocalization', '-lscipolynomials', '-lsciio', '-lscielementary_functions', '-lscisparse', '-lscihistory_manager', '-lscihistory_browser', '-lscigraphics', '-lscicompletion', '-lscifunctions', '-lsciboolean', '-lsciwindows_tools', '-lscitime', '-lscifftw', '-lsciintersci', '-lscidouble', '-lscicommons']
-+ sci_extra_link_args = ['-Wl,--no-as-needed', '-lscilab']
- else:
- raise NotImplementedError, "Only 'nt' and 'posix' are supported"
-