summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2023-05-11 13:48:47 +0200
committerMartin Diehl2023-05-11 13:50:58 +0200
commitb46a76168d8032ab5f772420ce9b0ec57e7c8753 (patch)
treea880299f0338be70e898bf473819f282b06d8038
parent074331fe0f917ea157cfa88d7c07faeb899e8bd3 (diff)
downloadaur-b46a76168d8032ab5f772420ce9b0ec57e7c8753.tar.gz
0.7.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--python-version.patch12
3 files changed, 8 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df1f7ae8eb4b..f8f3b3f90ac9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-scooby
pkgdesc = A Great Dane turned Python environment detective
- pkgver = 0.7.1
- pkgrel = 4
+ pkgver = 0.7.2
+ pkgrel = 1
url = https://github.com/banesullivan/scooby
arch = any
license = MIT
@@ -10,9 +10,7 @@ pkgbase = python-scooby
makedepends = python-wheel
makedepends = python-setuptools-scm
depends = python
- source = https://files.pythonhosted.org/packages/source/s/scooby/scooby-0.7.1.tar.gz
- source = python-version.patch
- sha512sums = 9cbac53dc97de0eb46f4d1cdb7ebc4a7f6a35f2ead234ee8a77aeff728661bfef02971accc8521bcee3de04d9f529e7c02a9664e8de677a5fba1e0256baa490b
- sha512sums = 46811a25d222bb9c98dbf6a7abb1cbffd81067485886d2469d7dff5b0c1f79380443030021af54ccf8cfcd340570541285d394a81ddb68b5f3617533ff44042f
+ source = https://files.pythonhosted.org/packages/source/s/scooby/scooby-0.7.2.tar.gz
+ sha512sums = 72eb95e79bd976cd7800d4caf8f15eb0f55ec3b9f33c1b1cd5323143fc0cd479e53fdca0ed64b1dfbac7d681ae3d6907daf7832e856c2ccb86d212ad1020abd7
pkgname = python-scooby
diff --git a/PKGBUILD b/PKGBUILD
index 29b3a61a012f..3afe0299a780 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Diehl <aur@martin-diehl.net>
-pkgver=0.7.1
-pkgrel=4
+pkgver=0.7.2
+pkgrel=1
pkgname=python-scooby
_name=${pkgname#python-}
pkgdesc='A Great Dane turned Python environment detective'
@@ -10,15 +10,8 @@ url='https://github.com/banesullivan/scooby'
license=('MIT')
depends=('python')
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
- python-version.patch)
-sha512sums=('9cbac53dc97de0eb46f4d1cdb7ebc4a7f6a35f2ead234ee8a77aeff728661bfef02971accc8521bcee3de04d9f529e7c02a9664e8de677a5fba1e0256baa490b'
- '46811a25d222bb9c98dbf6a7abb1cbffd81067485886d2469d7dff5b0c1f79380443030021af54ccf8cfcd340570541285d394a81ddb68b5f3617533ff44042f')
-
-prepare() {
- cd "$_name-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/python-version.patch"
-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha512sums=('72eb95e79bd976cd7800d4caf8f15eb0f55ec3b9f33c1b1cd5323143fc0cd479e53fdca0ed64b1dfbac7d681ae3d6907daf7832e856c2ccb86d212ad1020abd7')
build() {
cd "$_name-$pkgver"
diff --git a/python-version.patch b/python-version.patch
deleted file mode 100644
index d79ede5fa776..000000000000
--- a/python-version.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --color -ur --text scooby-0.7.1.orig/setup.py scooby-0.7.1.new/setup.py
---- scooby-0.7.1.orig/setup.py 2023-02-16 12:14:14.886929678 +0100
-+++ scooby-0.7.1.new/setup.py 2023-02-16 12:14:31.566938366 +0100
-@@ -28,7 +28,7 @@
- 'Intended Audience :: Science/Research',
- 'Natural Language :: English',
- ),
-- python_requires='>=3.7.*',
-+ python_requires='>=3.7',
- extras_require={
- 'cpu': ['psutil', 'mkl'],
- # 'gpu': [], # TODO: what's needed?