summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2020-05-07 17:05:55 -0400
committerTed Alff2020-05-07 17:05:55 -0400
commit8a695370925396772e104e6eb7fc60dac1582936 (patch)
tree006b475e4696ca27329de861163a85061bfd8803
parentf8196cd31adb2522d0a74b4992745455713a5d89 (diff)
downloadaur-8a695370925396772e104e6eb7fc60dac1582936.tar.gz
Don't require python-dataclasses: part of core python since 3.7
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c87d2764053..dbf10bc08403 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = python-screeninfo
pkgdesc = Python library to fetch location and size of physical screens
pkgver = 0.6.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/rr-/screeninfo
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- depends = python-dataclasses
optdepends = libxinerama: xinerama backend
optdepends = libxrandr: randr backend
optdepends = libdrm: experimental DRM backend
source = python-screeninfo-0.6.5.tar.gz::https://github.com/rr-/screeninfo/archive/0.6.5.tar.gz
+ source = dont_require_dataclasses.patch::https://github.com/rr-/screeninfo/commit/3dcaa513732f4dec236187ef227580975ce5f01c.patch
sha256sums = 06ef4146276bd4f8a3635fff44324c0a4e86b200155dea089da96ae4cd1741a6
+ sha256sums = 18c8f4be21d4a3413c63e4e3d61c255615b23d86706c880ab05139b6525721c8
pkgname = python-screeninfo
diff --git a/PKGBUILD b/PKGBUILD
index cb9520efddc4..971cd1493c1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,25 @@
pkgname=python-screeninfo
pkgver=0.6.5
-pkgrel=2
+pkgrel=3
pkgdesc="Python library to fetch location and size of physical screens"
arch=('any')
url="https://github.com/rr-/screeninfo"
license=('MIT')
-depends=('python' 'python-dataclasses')
+depends=('python')
optdepends=('libxinerama: xinerama backend'
'libxrandr: randr backend'
'libdrm: experimental DRM backend')
makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/rr-/${pkgname/python-/}/archive/${pkgver}.tar.gz")
-sha256sums=('06ef4146276bd4f8a3635fff44324c0a4e86b200155dea089da96ae4cd1741a6')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/rr-/${pkgname/python-/}/archive/${pkgver}.tar.gz"
+ 'dont_require_dataclasses.patch::https://github.com/rr-/screeninfo/commit/3dcaa513732f4dec236187ef227580975ce5f01c.patch')
+sha256sums=('06ef4146276bd4f8a3635fff44324c0a4e86b200155dea089da96ae4cd1741a6'
+ '18c8f4be21d4a3413c63e4e3d61c255615b23d86706c880ab05139b6525721c8')
+
+prepare() {
+ cd "${srcdir}/${pkgname/python-/}-${pkgver}"
+ patch -Np1 -i ../dont_require_dataclasses.patch
+}
package() {
cd "${srcdir}/${pkgname/python-/}-${pkgver}"