summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-09-05 16:07:16 -0400
committerGuillaume Horel2017-09-05 16:07:28 -0400
commit39c42912490249e72a956adb47ff8c8c9b561596 (patch)
treea0515e3af8ef4beaf88ccde6b8c6be69c4c2ff86
parent3227a7af3d013c56cf66b92667bf59b08998b810 (diff)
downloadaur-39c42912490249e72a956adb47ff8c8c9b561596.tar.gz
version bump
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE.txt21
-rw-r--r--PKGBUILD17
3 files changed, 35 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc088ec8e81e..9573a65eb3fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-scs
pkgdesc = Convex cone solver via operator splitting.
- pkgver = 1.2.6
+ pkgver = 1.2.7
pkgrel = 1
url = http://github.com/cvxgrp/scs/
arch = i686
@@ -8,8 +8,10 @@ pkgbase = python-scs
license = MIT
makedepends = python-setuptools
depends = python
- source = https://github.com/cvxgrp/scs/archive/v1.2.6.tar.gz
- sha256sums = b4bebb43a1257b6e88a5f97c855c0559d6c8a8c0548d3156fc5a28d82bb9533f
+ source = https://pypi.org/packages/source/s/scs/scs-1.2.7.tar.gz
+ source = LICENSE.txt
+ sha256sums = e284517e31bd8aac2e1e022376c46bade26d55ce4ef078cf796a9e70ab2b2433
+ sha256sums = 47d0bba3f33546d08d9dea012d70b1362d2e917553bb751183fcf046519fd868
pkgname = python-scs
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..3b25314d460a
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2012 Brendan O'Donoghue (bodonoghue85@gmail.com)
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 9240622ac9d3..ecd84c0bdd15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=('python-scs')
-_module='scs'
-pkgver='1.2.6'
+_pkgname='scs'
+pkgver='1.2.7'
pkgrel=1
pkgdesc="Convex cone solver via operator splitting."
url="http://github.com/cvxgrp/scs/"
@@ -8,17 +8,18 @@ depends=('python')
makedepends=('python-setuptools')
license=('MIT')
arch=('i686' 'x86_64')
-source=("https://github.com/cvxgrp/scs/archive/v${pkgver}.tar.gz")
-sha256sums=('b4bebb43a1257b6e88a5f97c855c0559d6c8a8c0548d3156fc5a28d82bb9533f')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+ "LICENSE.txt")
+sha256sums=('e284517e31bd8aac2e1e022376c46bade26d55ce4ef078cf796a9e70ab2b2433'
+ '47d0bba3f33546d08d9dea012d70b1362d2e917553bb751183fcf046519fd868')
build() {
- cd "${srcdir}/${_module}-${pkgver}/python"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
- install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.TXT"
- cd "python"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 ../../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}