summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-09-11 17:10:47 +0200
committerPhilipp A2019-09-11 17:10:47 +0200
commite0fab93a041253a65208f665cdf7b3389a6e6aaf (patch)
treeaf75db281e75bb663f5abb5ef20a6c5992f1064c
downloadaur-e0fab93a041253a65208f665cdf7b3389a6e6aaf.tar.gz
init
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a895c2f4f7e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-scvelo
+ pkgdesc = Stochastic Single Cell RNA Velocity
+ pkgver = 0.1.21
+ pkgrel = 1
+ url = https://github.com/theislab/scvelo
+ arch = any
+ license = BSD
+ depends = scanpy>=1.3.3
+ depends = python-anndata>=0.6.18
+ depends = python-numpy>=1.14
+ depends = python-pandas>=0.23.0
+ depends = python-matplotlib>=2.2
+ depends = python-umap-learn>=0.3.0
+ depends = python-loompy>=2.0.12
+ depends = python-scipy>=1.0
+ depends = python-scikit-learn>=0.21.2
+ depends = python-joblib
+ depends = python-setuptools
+ noextract = scvelo-0.1.21-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/s/scvelo/scvelo-0.1.21-py3-none-any.whl
+ sha256sums = 0eaf59b5d4ca52415c2af380f3c1c1764236efb955022aa4d76c4197856e056d
+
+pkgname = python-scvelo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3cc40a81f9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.tar.xz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ff458d54c6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=scvelo
+pkgname=python-$_name
+pkgver=0.1.21
+pkgrel=1
+pkgdesc='Stochastic Single Cell RNA Velocity'
+arch=(any)
+url="https://github.com/theislab/$_name"
+license=(BSD)
+depends=(
+ 'scanpy>=1.3.3'
+ 'python-anndata>=0.6.18'
+ 'python-numpy>=1.14'
+ 'python-pandas>=0.23.0'
+ 'python-matplotlib>=2.2'
+ 'python-umap-learn>=0.3.0'
+ 'python-loompy>=2.0.12'
+ 'python-scipy>=1.0'
+ 'python-scikit-learn>=0.21.2'
+ 'python-joblib'
+ 'python-setuptools'
+)
+_pyarch=py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('0eaf59b5d4ca52415c2af380f3c1c1764236efb955022aa4d76c4197856e056d')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}