summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorigo958622021-07-18 19:42:27 +0300
committerigo958622021-07-18 19:42:27 +0300
commit5181dfefa52b3e961a1728a81f48ede324a70ddb (patch)
treef0e711872db55d333ebf2b5e8b4f1537cc9b6905
parent1342bcabb2c7308e9cf3a7eb22e5a7f8a275fda0 (diff)
downloadaur-5181dfefa52b3e961a1728a81f48ede324a70ddb.tar.gz
Added networkmanager package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD36
2 files changed, 40 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18b4235fb230..4f744f26049e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sdbus-git
pkgdesc = Modern Python library for D-Bus
- pkgver = r396.6e72fc4
+ pkgver = r469.14ba27e
pkgrel = 1
url = https://github.com/igo95862/python-sdbus
arch = x86_64
@@ -11,15 +11,24 @@ pkgbase = python-sdbus-git
depends = python
depends = systemd-libs
source = python-sdbus-git::git+https://github.com/igo95862/python-sdbus
+ source = python-sdbus-notifications::git+https://github.com/igo95862/python-sdbus-notifications
+ source = python-sdbus-networkmanager::git+https://github.com/igo95862/python-sdbus-networkmanager
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = python-sdbus-git
optdepends = python-jinja: Code generator for dbus XML introspection
optdepends = python-sphinx: Autodoc for dbus members
provides = python-sdbus
+ conflicts = python-sdbus
pkgname = python-sdbus-notifications-git
pkgdesc = Freedesktop Notifications binds for python-sdbus
depends = python-sdbus
provides = python-sdbus-notifications
+pkgname = python-sdbus-networkmanager-git
+ pkgdesc = NetworkManager binds for python-sdbus
+ depends = python-sdbus
+ provides = python-sdbus-networkmanager
diff --git a/PKGBUILD b/PKGBUILD
index 4ffa69793c4a..41a65990e9db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,11 @@
# Maintainer: igo95862 <address at domain dot tld>
-pkgname=('python-sdbus-git' 'python-sdbus-notifications-git')
+pkgname=(
+ 'python-sdbus-git'
+ 'python-sdbus-notifications-git'
+ 'python-sdbus-networkmanager-git'
+)
pkgbase='python-sdbus-git'
-pkgver=r396.6e72fc4
+pkgver=r469.14ba27e
pkgrel=1
pkgdesc="Modern Python library for D-Bus"
arch=('x86_64')
@@ -9,8 +13,16 @@ url="https://github.com/igo95862/python-sdbus"
license=('LGPL-2.1-or-later')
depends=('python' 'systemd-libs')
makedepends=('git' 'python-setuptools' 'gcc')
-source=("$pkgbase"::"git+https://github.com/igo95862/python-sdbus")
-md5sums=('SKIP')
+source=(
+ "$pkgbase"::"git+https://github.com/igo95862/python-sdbus"
+ "python-sdbus-notifications"::"git+https://github.com/igo95862/python-sdbus-notifications"
+ "python-sdbus-networkmanager"::"git+https://github.com/igo95862/python-sdbus-networkmanager"
+)
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd "$srcdir/$pkgbase"
@@ -21,7 +33,10 @@ build () {
cd "$srcdir/$pkgbase"
python setup.py build
- cd interfaces/notifications
+ cd "$srcdir/python-sdbus-notifications"
+ python setup.py build
+
+ cd "$srcdir/python-sdbus-networkmanager"
python setup.py build
}
@@ -34,6 +49,7 @@ check () {
package_python-sdbus-git() {
provides=('python-sdbus')
+ conflicts=('python-sdbus')
optdepends=(
'python-jinja: Code generator for dbus XML introspection'
'python-sphinx: Autodoc for dbus members'
@@ -46,6 +62,14 @@ package_python-sdbus-notifications-git() {
provides=('python-sdbus-notifications')
pkgdesc='Freedesktop Notifications binds for python-sdbus'
depends=('python-sdbus')
- cd "$srcdir/$pkgbase"/interfaces/notifications
+ cd "$srcdir"/python-sdbus-notifications
+ python setup.py install --prefix /usr --root "$pkgdir"
+}
+
+package_python-sdbus-networkmanager-git() {
+ provides=('python-sdbus-networkmanager')
+ pkgdesc='NetworkManager binds for python-sdbus'
+ depends=('python-sdbus')
+ cd "$srcdir"/python-sdbus-networkmanager
python setup.py install --prefix /usr --root "$pkgdir"
}