summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorigo958622021-10-09 17:00:46 +0300
committerigo958622021-10-09 17:00:46 +0300
commit58a1796483b38cb8d1e8d6064097323c82ad021c (patch)
treecc768288a571f492b0e20e0042e61e0008c2f189
parent5181dfefa52b3e961a1728a81f48ede324a70ddb (diff)
downloadaur-58a1796483b38cb8d1e8d6064097323c82ad021c.tar.gz
Added -sercrets package
Also use new python-sdbus URLs.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 32 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f744f26049e..bed3c4fccf3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = python-sdbus-git
pkgdesc = Modern Python library for D-Bus
- pkgver = r469.14ba27e
+ pkgver = r534.f59d2d7
pkgrel = 1
- url = https://github.com/igo95862/python-sdbus
+ url = https://github.com/python-sdbus/python-sdbus
arch = x86_64
- license = LGPL-2.1-or-later
+ license = LGPL2.1
makedepends = git
makedepends = python-setuptools
makedepends = gcc
depends = python
depends = systemd-libs
- source = python-sdbus-git::git+https://github.com/igo95862/python-sdbus
- source = python-sdbus-notifications::git+https://github.com/igo95862/python-sdbus-notifications
- source = python-sdbus-networkmanager::git+https://github.com/igo95862/python-sdbus-networkmanager
+ source = python-sdbus-git::git+https://github.com/python-sdbus/python-sdbus
+ source = python-sdbus-notifications::git+https://github.com/python-sdbus/python-sdbus-notifications
+ source = python-sdbus-networkmanager::git+https://github.com/python-sdbus/python-sdbus-networkmanager
+ source = python-sdbus-secrets::git+https://github.com/python-sdbus/python-sdbus-secrets
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
@@ -25,10 +27,12 @@ pkgname = python-sdbus-git
pkgname = python-sdbus-notifications-git
pkgdesc = Freedesktop Notifications binds for python-sdbus
+ arch = any
depends = python-sdbus
provides = python-sdbus-notifications
pkgname = python-sdbus-networkmanager-git
pkgdesc = NetworkManager binds for python-sdbus
+ arch = any
depends = python-sdbus
provides = python-sdbus-networkmanager
diff --git a/PKGBUILD b/PKGBUILD
index 41a65990e9db..06f28de16195 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,25 @@ pkgname=(
'python-sdbus-networkmanager-git'
)
pkgbase='python-sdbus-git'
-pkgver=r469.14ba27e
+pkgver=r534.f59d2d7
pkgrel=1
pkgdesc="Modern Python library for D-Bus"
arch=('x86_64')
-url="https://github.com/igo95862/python-sdbus"
-license=('LGPL-2.1-or-later')
+url="https://github.com/python-sdbus/python-sdbus"
+license=('LGPL2.1')
depends=('python' 'systemd-libs')
makedepends=('git' 'python-setuptools' 'gcc')
source=(
- "$pkgbase"::"git+https://github.com/igo95862/python-sdbus"
- "python-sdbus-notifications"::"git+https://github.com/igo95862/python-sdbus-notifications"
- "python-sdbus-networkmanager"::"git+https://github.com/igo95862/python-sdbus-networkmanager"
+ "$pkgbase"::"git+https://github.com/python-sdbus/python-sdbus"
+ "python-sdbus-notifications"::"git+https://github.com/python-sdbus/python-sdbus-notifications"
+ "python-sdbus-networkmanager"::"git+https://github.com/python-sdbus/python-sdbus-networkmanager"
+ "python-sdbus-secrets"::"git+https://github.com/python-sdbus/python-sdbus-secrets"
)
md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
pkgver() {
@@ -38,6 +40,9 @@ build () {
cd "$srcdir/python-sdbus-networkmanager"
python setup.py build
+
+ cd "$srcdir/python-sdbus-secrets"
+ python setup.py build
}
check () {
@@ -62,6 +67,7 @@ package_python-sdbus-notifications-git() {
provides=('python-sdbus-notifications')
pkgdesc='Freedesktop Notifications binds for python-sdbus'
depends=('python-sdbus')
+ arch=('any')
cd "$srcdir"/python-sdbus-notifications
python setup.py install --prefix /usr --root "$pkgdir"
}
@@ -70,6 +76,16 @@ package_python-sdbus-networkmanager-git() {
provides=('python-sdbus-networkmanager')
pkgdesc='NetworkManager binds for python-sdbus'
depends=('python-sdbus')
+ arch=('any')
cd "$srcdir"/python-sdbus-networkmanager
python setup.py install --prefix /usr --root "$pkgdir"
}
+
+package_python-sdbus-secrets-git() {
+ provides=('python-sdbus-secrets')
+ pkgdesc='Freedesktop secrets binds for python-sdbus'
+ depends=('python-sdbus')
+ arch=('any')
+ cd "$srcdir"/python-sdbus-secrets
+ python setup.py install --prefix /usr --root "$pkgdir"
+}