summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-03-12 21:16:43 +0000
committerGrey Christoforo2017-03-12 21:16:43 +0000
commitd8608a4ae1f9613ef358da263068060f181536a8 (patch)
tree3178114637bc5644dd715ca8b2e1a148ed32c193
downloadaur-d8608a4ae1f9613ef358da263068060f181536a8.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2da116ba7a8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Mar 12 21:16:40 UTC 2017
+pkgbase = python-sdds
+ pkgdesc = Pure python parser for the sdds file format
+ pkgver = 0.12
+ pkgrel = 1
+ url = https://github.com/greyltc/python-sdds/
+ arch = any
+ license = MIT
+ depends = python-numpy
+ source = https://github.com/greyltc/python-sdds/archive/v0.12.tar.gz
+ md5sums = 8b59f4281d89efffd361943661372556
+
+pkgname = python-sdds
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93f5d9f2777e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81ec123f9f2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# $Id$
+# Maintainer: Grey Christoforo <grey at christoforo dot net>
+
+pkgname=python-sdds
+pkgver=0.12
+pkgrel=1
+pkgdesc="Pure python parser for the sdds file format"
+arch=('any')
+url="https://github.com/greyltc/python-sdds/"
+license=('MIT')
+depends=('python-numpy')
+source=("https://github.com/greyltc/python-sdds/archive/v0.12.tar.gz")
+md5sums=('8b59f4281d89efffd361943661372556')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}