summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandr Beliaev2020-06-01 12:01:49 +1200
committerAleksandr Beliaev2020-06-01 12:01:49 +1200
commit1d137160586576444da1f1bf130046887fc22af6 (patch)
treec95c20ddd90c388c23f1d4ce8233d930337ad741
downloadaur-1d137160586576444da1f1bf130046887fc22af6.tar.gz
Initial commit - Seafile v.7.1.4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--setup.py14
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ef83a9a6167
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-seafobj
+ pkgdesc = Python library for accessing seafile data model
+ pkgver = 7.1.4
+ pkgrel = 1
+ url = https://github.com/haiwen/seafobj
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/haiwen/seafobj/archive/v7.1.4-server.tar.gz
+ source = setup.py
+ sha256sums = 2d74169c6e3f9029dc2dcd866f407b1ec92c2a19f74d5ae4d2a99ca51460c41c
+ sha256sums = 062d753f4289f28cc30e639c50f301b07a6f20a2f2caa3bbc1e5ae1741f6c692
+
+pkgname = python-seafobj
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f8280b0be7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Aleksandr Beliaev <trap000d@gmail.com>
+
+_pkgname=seafobj
+pkgname=python-$_pkgname
+pkgver=7.1.4
+pkgrel=1
+pkgdesc="Python library for accessing seafile data model"
+arch=('any')
+url="https://github.com/haiwen/seafobj"
+license=('Apache')
+depends=('python')
+makedepends=('python-setuptools')
+source=("${url}/archive/v${pkgver}-server.tar.gz"
+ "setup.py")
+sha256sums=('2d74169c6e3f9029dc2dcd866f407b1ec92c2a19f74d5ae4d2a99ca51460c41c'
+ '062d753f4289f28cc30e639c50f301b07a6f20a2f2caa3bbc1e5ae1741f6c692'
+ )
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver-server"
+ python ../setup.py install --root="$pkgdir/" --optimize=1
+}
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..8c014de6ce40
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,14 @@
+#!/usr/bin/env python
+
+from setuptools import find_packages, setup
+
+setup(
+ name = "seafobj",
+ version = "7.1.4",
+ author = "Seafile Ltd.",
+ author_email = "info@seafile.com",
+ description = ("Python library for accessing seafile data model"),
+ license = "Apache2",
+ url = "https://github.com/haiwen/seafobj",
+ packages = find_packages(exclude=["test.*", "test"])
+)