summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2022-04-29 07:55:35 -0700
committerMaximilian Weiss2022-04-29 07:55:35 -0700
commitea2efd2b682233c847bd2b99798d6a47d21f0e9f (patch)
tree32af23b578e53086939d5d78de309eeecd6a96b1
parent8274385f83587e0d2987907f640dc8ed3a682b46 (diff)
downloadaur-ea2efd2b682233c847bd2b99798d6a47d21f0e9f.tar.gz
Update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0e9730062ff..b97f8cfd03fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-secp256k1-git
pkgdesc = Python FFI bindings for libsecp256k1
- pkgver = 0.13.2.4.2.gf5e4552
- pkgrel = 5
- url = https://github.com/ludbb/secp256k1-py
+ pkgver = r0.g0
+ pkgrel = 1
+ url = https://github.com/rustyrussell/secp256k1-py
arch = any
license = MIT
depends = python-cffi
depends = python-pycparser
depends = libsecp256k1
+ depends = coreutils
provides = python-secp256k1-git
provides = python-secp256k1
conflicts = python-secp256k1
- source = git+https://github.com/ludbb/secp256k1-py
+ source = git+https://github.com/rustyrussell/secp256k1-py
sha256sums = SKIP
pkgname = python-secp256k1-git
diff --git a/PKGBUILD b/PKGBUILD
index 99bd18f12c74..da8c14813d0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
# Maintainer: Maximilian Weiss <$(echo "bWF4QG1heHdlaXNzLmlv" | base64 -d)>
+# Contributor: Rusty Russell
# Contributor: Ludvig Broberg
# Contributor: Amir Taaki
# Contributor: The Bitcoin Core Developers
pkgname=python-secp256k1-git
-pkgver=0.13.2.4.2.gf5e4552
-pkgrel=5
+pkgver=r0.g0
+pkgrel=1
pkgdesc='Python FFI bindings for libsecp256k1'
arch=('any')
-url='https://github.com/ludbb/secp256k1-py'
+url='https://github.com/rustyrussell/secp256k1-py'
license=('MIT')
-depends=('python-cffi' 'python-pycparser' 'libsecp256k1')
+depends=('python-cffi' 'python-pycparser' 'libsecp256k1' 'coreutils')
provides=('python-secp256k1-git' 'python-secp256k1')
conflicts=('python-secp256k1')
-source=('git+https://github.com/ludbb/secp256k1-py')
+source=('git+https://github.com/rustyrussell/secp256k1-py')
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/secp256k1-py/"
- git describe | sed 's/-/./g'
+ echo -n "r$(git rev-list --all --count).g$(git rev-parse --short HEAD)"
}
package() {
cd "$srcdir/secp256k1-py/"
- python setup.py install --root="$pkgdir/" --optimize=1 --prefix=/usr
+ env PYTHON_KEYRING_BACKEND=keyring.backends.null.Keyring python setup.py install --root="$pkgdir/" --optimize=1 --prefix=/usr
}