summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Mastykov2015-06-24 13:07:44 +0300
committerSergey Mastykov2015-06-24 13:07:44 +0300
commitcf5945dc1be14b0843c9f31aebacb51dcec0fdd1 (patch)
treedbbe8aba43600d3561cb3e402c4e49620b75bbe7
downloadaur-cf5945dc1be14b0843c9f31aebacb51dcec0fdd1.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2551bf5d9b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-selection
+ pkgdesc = API to extract content from HTML & XML documents
+ pkgver = 0.0.9
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/selection
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python2
+ source = https://pypi.python.org/packages/source/s/selection/selection-0.0.9.tar.gz
+ sha256sums = 2e89d6eea792447a7c23da77b81fd7df84526791f64cbff4a50edf363697759e
+
+pkgname = python-selection
+ depends = python
+ depends = python-lxml
+ depends = python-six
+ depends = python-weblib
+
+pkgname = python2-selection
+ depends = python2
+ depends = python2-lxml
+ depends = python2-six
+ depends = python2-weblib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e9bdce4d936
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
+# Contributor: Sergey Mastykov <smastykov[at]gmail[dot]com>
+
+pkgbase=python-selection
+pkgname=('python-selection' 'python2-selection')
+pkgver=0.0.9
+pkgrel=1
+pkgdesc="API to extract content from HTML & XML documents"
+arch=('any')
+url="https://pypi.python.org/pypi/selection"
+license=('MIT')
+makedepends=('python' 'python2')
+source=(https://pypi.python.org/packages/source/s/selection/selection-${pkgver}.tar.gz)
+sha256sums=('2e89d6eea792447a7c23da77b81fd7df84526791f64cbff4a50edf363697759e')
+
+build() {
+ cd $srcdir
+ cp -r selection-$pkgver selection2-$pkgver
+}
+
+check() {
+ cd $srcdir/selection-$pkgver
+ python3 setup.py check
+
+ cd $srcdir/selection2-$pkgver
+ python2 setup.py check
+}
+
+package_python-selection() {
+ depends=('python' 'python-lxml' 'python-six' 'python-weblib')
+ cd "$srcdir/selection-$pkgver"
+ python3 setup.py install --root "${pkgdir}" --optimize=1
+}
+
+package_python2-selection() {
+ depends=('python2' 'python2-lxml' 'python2-six' 'python2-weblib')
+ cd "$srcdir/selection2-$pkgver"
+ python2 setup.py install --root "${pkgdir}" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: