summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2016-01-25 19:58:23 -0500
committerbrent s2016-01-25 19:58:23 -0500
commit7a3458069d744550640eed026def72c7f762262b (patch)
tree8861cec464552e888a23d0300194ad91114a90bc
downloadaur-7a3458069d744550640eed026def72c7f762262b.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6819314bc6a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 00:58:23 UTC 2016
+pkgbase = python-semantic_version
+ pkgdesc = This is a Python library for parsing version strings via SemVer.
+ pkgver = 2.4.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/semantic_version/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = python
+ source = https://pypi.python.org/packages/source/d/semantic_version/semantic_version-2.4.2.tar.gz
+ md5sums = fd7d5ade76e78d8540b9a4044496a57c
+
+pkgname = python-semantic_version
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7228da671ad1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+pkgname=python-semantic_version
+_pkgname=semantic_version
+pkgver=2.4.2
+pkgrel=1
+pkgdesc="This is a Python library for parsing version strings via SemVer."
+arch=('i686' 'x86_64')
+url=("https://pypi.python.org/pypi/semantic_version/")
+license=('custom')
+depends=('python')
+source=("https://pypi.python.org/packages/source/d/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('fd7d5ade76e78d8540b9a4044496a57c')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py build install --root="${pkgdir}"
+}
+