summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-07-06 12:32:04 -0600
committerMark Wagie2021-07-06 12:32:04 -0600
commit065a037f2bb1fd36acd59f0e64e6673458b33f69 (patch)
treec3bca304b2d376427a90f863127ae2bbe76f555c
parentf9eb770030bdfc3c2e4309d4eb2e20e7b4faa1af (diff)
downloadaur-065a037f2bb1fd36acd59f0e64e6673458b33f69.tar.gz
1.2.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD28
2 files changed, 30 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5060bc9d4d9..3700d0b4a0d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sentry_sdk
pkgdesc = The new Python SDK for Sentry.io
- pkgver = 1.1.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://sentry.io/for/python
arch = any
@@ -8,25 +8,26 @@ pkgbase = python-sentry_sdk
makedepends = python-setuptools
depends = python-urllib3
depends = python-certifi
- optdepends = python-flask: adds support for the Flask Web Framework
- optdepends = python-blinker
+ optdepends = python-aiohttp: adds support for the AIOHTTP-Server Web Framework
+ optdepends = python-asgiref: adds support for ASGI
+ optdepends = python-apache-beam: experimental BeamIntegration
optdepends = python-bottle: adds support for the Bottle Web Framework
- optdepends = python-falcon: adds support for the Falcon Web Framework
- optdepends = python-django: adds support for the Django Web Framework
- optdepends = python-sanic: adds support for the Sanic Web Framework
optdepends = python-celery: adds support for the Celery Task Queue System
- optdepends = python-apache-beam: experimental BeamIntegration
+ optdepends = python-chalice: for the Chalice web framework for AWS Lambda
+ optdepends = python-django: adds support for the Django Web Framework
+ optdepends = python-falcon: adds support for the Falcon Web Framework
+ optdepends = python-flask: adds support for the Flask Web Framework
+ optdepends = python-httpx: Httpx integration
+ optdepends = python-pyramid: adds support for the Pyramid Web Framework
+ optdepends = python-pyspark: adds support for the Python API for Apache Spark
optdepends = python-rq: adds support for the RQ Job Queue System
- optdepends = python-aiohttp: adds support for the AIOHTTP-Server Web Framework
+ optdepends = python-sanic: adds support for the Sanic Web Framework
optdepends = python-tornado: adds support for the Tornado Web Framework
+ optdepends = python-trytond: adds support for the Tryton Framework Server
optdepends = python-sqlalchemy: captures queries from SQLAlchemy as breadcrumbs
- optdepends = python-pyspark: adds support for the Python API for Apache Spark
optdepends = python-pure_eval: for richer stacktraces & additional variables
optdepends = python-executing: for richer stacktraces & better function names
- optdepends = python-asttokens
- optdepends = python-chalice: for the Chalice web framework for AWS Lambda
- source = https://pypi.org/packages/source/s/sentry-sdk/sentry-sdk-1.1.0.tar.gz
- sha256sums = c1227d38dca315ba35182373f129c3e2722e8ed999e52584e6aca7d287870739
+ source = https://pypi.org/packages/source/s/sentry-sdk/sentry-sdk-1.2.0.tar.gz
+ sha256sums = 9907adbdd30a55b818914512cc143e6beae0bb3ba78b2649f4b079752eb0e424
pkgname = python-sentry_sdk
-
diff --git a/PKGBUILD b/PKGBUILD
index 67032184ec37..1df131d3df7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-sentry_sdk
_name=sentry-sdk
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="The new Python SDK for Sentry.io"
arch=('any')
@@ -9,25 +9,27 @@ url="https://sentry.io/for/python"
license=('BSD')
depends=('python-urllib3' 'python-certifi')
makedepends=('python-setuptools')
-optdepends=('python-flask: adds support for the Flask Web Framework'
- 'python-blinker'
+optdepends=('python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
+ 'python-asgiref: adds support for ASGI'
+ 'python-apache-beam: experimental BeamIntegration'
'python-bottle: adds support for the Bottle Web Framework'
- 'python-falcon: adds support for the Falcon Web Framework'
- 'python-django: adds support for the Django Web Framework'
- 'python-sanic: adds support for the Sanic Web Framework'
'python-celery: adds support for the Celery Task Queue System'
- 'python-apache-beam: experimental BeamIntegration'
+ 'python-chalice: for the Chalice web framework for AWS Lambda'\
+ 'python-django: adds support for the Django Web Framework'
+ 'python-falcon: adds support for the Falcon Web Framework'
+ 'python-flask: adds support for the Flask Web Framework'
+ 'python-httpx: Httpx integration'
+ 'python-pyramid: adds support for the Pyramid Web Framework'
+ 'python-pyspark: adds support for the Python API for Apache Spark'
'python-rq: adds support for the RQ Job Queue System'
- 'python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
+ 'python-sanic: adds support for the Sanic Web Framework'
'python-tornado: adds support for the Tornado Web Framework'
+ 'python-trytond: adds support for the Tryton Framework Server'
'python-sqlalchemy: captures queries from SQLAlchemy as breadcrumbs'
- 'python-pyspark: adds support for the Python API for Apache Spark'
'python-pure_eval: for richer stacktraces & additional variables'
- 'python-executing: for richer stacktraces & better function names'
- 'python-asttokens'
- 'python-chalice: for the Chalice web framework for AWS Lambda')
+ 'python-executing: for richer stacktraces & better function names')
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('c1227d38dca315ba35182373f129c3e2722e8ed999e52584e6aca7d287870739')
+sha256sums=('9907adbdd30a55b818914512cc143e6beae0bb3ba78b2649f4b079752eb0e424')
build() {
cd "$_name-$pkgver"