summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2018-10-08 18:44:03 -0600
committerMark Wagie2018-10-08 18:44:03 -0600
commite511cd1951f2443308b9a58c4ccae1d9365d6790 (patch)
tree571931a9e439701fb99b4909907569f44fdc1e74
downloadaur-e511cd1951f2443308b9a58c4ccae1d9365d6790.tar.gz
initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD21
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f79d67b4ea7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-sentry_sdk
+ pkgdesc = The new Python SDK for Sentry.io
+ pkgver = 0.3.11
+ pkgrel = 1
+ url = https://github.com/getsentry/sentry-python
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-urllib3
+ depends = python-certifi
+ depends = python-flask
+ source = python-sentry_sdk-0.3.11.tar.gz::https://github.com/getsentry/sentry-python/releases/download/0.3.11/sentry-sdk-0.3.11.tar.gz
+ source = LICENSE
+ md5sums = 3df682e01ba421258f709890b31a15e4
+ md5sums = 0c79f8d3c91fc847350efd28bfe0a341
+
+pkgname = python-sentry_sdk
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..61555f192e52
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Copyright (c) 2018 Sentry (https://sentry.io) and individual contributors.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01fb5df225c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=python-sentry_sdk
+_pkgname=sentry-sdk
+pkgver=0.3.11
+pkgrel=1
+pkgdesc="The new Python SDK for Sentry.io"
+arch=('i686' 'x86_64')
+url="https://github.com/getsentry/sentry-python"
+license=('BSD')
+depends=('python-urllib3' 'python-certifi' 'python-flask')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/releases/download/$pkgver/sentry-sdk-$pkgver.tar.gz"
+ "LICENSE")
+md5sums=('3df682e01ba421258f709890b31a15e4'
+ '0c79f8d3c91fc847350efd28bfe0a341')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}