summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2019-03-15 05:19:38 +0100
committerkpcyrd2019-03-15 05:19:38 +0100
commitdf24c911bf227b96fdbcc1b616053d7672b8219e (patch)
treee7795c87356a9527de54d4d3f071e4010a7b1bdf
downloadaur-df24c911bf227b96fdbcc1b616053d7672b8219e.tar.gz
v2.1.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..399413c2444e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-sepaxml
+ pkgdesc = SEPA Direct Debit XML generation in python
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/raphaelm/python-sepaxml
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-pytest
+ depends = python-lxml
+ depends = python-text-unidecode
+ depends = python-xmlschema
+ source = python-sepaxml-2.1.0.tar.gz::https://github.com/raphaelm/python-sepaxml/archive/2.1.0.tar.gz
+ sha512sums = 8ce9d29bb75b111df14b2adb5dffc4c92b90beee6426e9aae166d82cd4f1bc9ba8cb84d4e65c9b51c3fac1fc62b5b7f25f3aa1b2fbda4566933bb297ed2d40a6
+
+pkgname = python-sepaxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99d3fbd0db8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: kpcyrd <git@rxv.cc>
+
+pkgname="python-sepaxml"
+pkgver="2.1.0"
+pkgrel=1
+pkgdesc="SEPA Direct Debit XML generation in python"
+arch=(any)
+url="https://github.com/raphaelm/python-sepaxml"
+license=('MIT')
+depends=('python-lxml' 'python-text-unidecode' 'python-xmlschema')
+makedepends=('python-setuptools' 'python-pytest')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/raphaelm/python-sepaxml/archive/${pkgver}.tar.gz)
+sha512sums=('8ce9d29bb75b111df14b2adb5dffc4c92b90beee6426e9aae166d82cd4f1bc9ba8cb84d4e65c9b51c3fac1fc62b5b7f25f3aa1b2fbda4566933bb297ed2d40a6')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ PYTHONPATH=. pytest
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install -O1 --root="${pkgdir}"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: