summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Whetter2015-06-08 12:13:44 +0100
committerAshley Whetter2015-06-08 12:13:44 +0100
commit842cd1c397853bfc1baeae055fcbd7c30f0ecefd (patch)
treee5c983273cee722ca143ebd5a580caac5014654c
downloadaur-842cd1c397853bfc1baeae055fcbd7c30f0ecefd.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..474f6294af1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-seqlearn-git
+ pkgdesc = A sequence classification toolkit for Python.
+ pkgver = 20141124
+ pkgrel = 1
+ url = http://larsmans.github.io/seqlearn/
+ arch = i686
+ arch = x86_64
+ license = custom: Copyright 2013-2014 Lars Buitinck / University of Amsterdam and contributors
+ makedepends = git
+ depends = python
+ depends = python-numpy>=1.6
+ depends = python-scipy>=0.11
+ depends = cython>=0.20.2
+ options = !emptydirs
+ source = git://github.com/larsmans/seqlearn.git
+ md5sums = SKIP
+
+pkgname = python-seqlearn-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8a8ffb28f97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ashley Whetter <(firstname) @ awhetter.co.uk>
+
+pkgname=python-seqlearn-git
+pkgver=20141124
+pkgrel=1
+pkgdesc="A sequence classification toolkit for Python."
+arch=('i686' 'x86_64')
+url="http://larsmans.github.io/seqlearn/"
+license=('custom: Copyright 2013-2014 Lars Buitinck / University of Amsterdam and contributors')
+groups=()
+depends=('python' 'python-numpy>=1.6' 'python-scipy>=0.11' 'cython>=0.20.2')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(git://github.com/larsmans/seqlearn.git)
+md5sums=("SKIP")
+
+package() {
+ cd "$srcdir/seqlearn"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: