summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-25 02:50:13 -0500
committerclintval2017-12-25 02:50:13 -0500
commit415c579d622e7f1f44c85354b9f5995ae6e9828c (patch)
tree32c6b4691c4ecc9faaaf382a079b2411f6573e4e
downloadaur-415c579d622e7f1f44c85354b9f5995ae6e9828c.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dff86ccc7da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-sercol
+ pkgdesc = Rich collection class with grouping and filtering helpers in Python
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/sercol
+ arch = x86_64
+ license = Apache2.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pandas
+ depends = python-serializable
+ depends = python-simplejson
+ options = !emptydirs
+ source = https://pypi.python.org/packages/ca/6a/2e99f1b7e37f3506bfa50894ad934249d1e2c6a97e6d01d49a2fc02fd805/sercol-0.1.0.tar.gz
+ md5sums = c4c793c5b0933aa0120ee24196837b97
+
+pkgname = python-sercol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30628660f50b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-sercol'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Rich collection class with grouping and filtering helpers in Python"
+arch=('x86_64')
+url="https://pypi.python.org/pypi/sercol"
+license=('Apache2.0')
+depends=('python' 'python-pandas' 'python-serializable' 'python-simplejson')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/ca/6a/2e99f1b7e37f3506bfa50894ad934249d1e2c6a97e6d01d49a2fc02fd805/sercol-0.1.0.tar.gz")
+md5sums=('c4c793c5b0933aa0120ee24196837b97')
+
+package() {
+ cd "${srcdir}/sercol-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}