summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-20 22:59:17 -0500
committerclintval2017-12-20 22:59:17 -0500
commit58ce785fc976d94e7a42310dea30a0a07acadc46 (patch)
treef1eca36818820ce6d6c0538f7fb9324e5cd8fdf8
downloadaur-58ce785fc976d94e7a42310dea30a0a07acadc46.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..708f9a0a78bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-serializable
+ pkgdesc = Base class with serialization helpers for user-defined Python objects
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/serializable
+ arch = any
+ license = Apache-2.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-simplejson
+ depends = python-six>=1.9.0
+ depends = python-typechecks>=0.0.2
+ source = https://pypi.python.org/packages/1a/8c/140c24214f503366c80cf9d42c474df2696ea5291bdd318c24d014a859db/serializable-0.1.1.tar.gz
+ md5sums = dfb019409549f16cfdf7f9496d01a7b9
+
+pkgname = python-serializable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10dfaab3fc45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-serializable'
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Base class with serialization helpers for user-defined Python objects"
+arch=('any')
+url="https://pypi.python.org/pypi/serializable"
+license=('Apache-2.0')
+depends=(
+ 'python'
+ 'python-simplejson'
+ 'python-six>=1.9.0'
+ 'python-typechecks>=0.0.2')
+optdepends=()
+makedepends=('python-setuptools')
+ptions=(!emptydirs)
+source=("https://pypi.python.org/packages/1a/8c/140c24214f503366c80cf9d42c474df2696ea5291bdd318c24d014a859db/serializable-${pkgver}.tar.gz")
+md5sums=('dfb019409549f16cfdf7f9496d01a7b9')
+
+package() {
+ cd "${srcdir}/serializable-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}