summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcol2020-08-03 16:47:02 +0100
committermcol2020-08-03 16:47:02 +0100
commit8c063977dc1c6cd53afa30a6b2228a9f9cccd039 (patch)
tree4363652cf95fe8021b77d32267961c76e520aa39
downloadaur-8c063977dc1c6cd53afa30a6b2228a9f9cccd039.tar.gz
populate with srcinfo and pkgbuild
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a92529b853f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-seriate
+ pkgdesc = Optimal ordering of elements in a set given their distance matrix.
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/src-d/seriate
+ arch = any
+ license = Apache2
+ makedepends = python-setuptools
+ depends = python-or-tools
+ depends = python-numpy
+ source = https://github.com/src-d/seriate/archive/1.1.2.tar.gz
+ sha256sums = 5e031e865398fbe24aebdbb4a2e0015447aec50478830850f29d38660fd266e3
+
+pkgname = python-seriate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..102a87d38b17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: mcol <mcol at posteo dot net>
+
+pkgname=python-seriate
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Optimal ordering of elements in a set given their distance matrix."
+arch=('any')
+url="https://github.com/src-d/seriate"
+license=('Apache2')
+depends=('python-or-tools' 'python-numpy')
+makedepends=('python-setuptools')
+source=("$url/archive/${pkgver}.tar.gz")
+sha256sums=('5e031e865398fbe24aebdbb4a2e0015447aec50478830850f29d38660fd266e3')
+
+build() {
+ cd "${srcdir}/seriate-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/seriate-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}