summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Javorski2020-06-10 21:34:16 -0700
committerMike Javorski2020-06-10 21:34:16 -0700
commit267dad503d705fa65e5de1eadc1491874f9b3789 (patch)
treec65799a9afc6dcdefc005a00ba07962e5454713d
downloadaur-python-serverlessrepo.tar.gz
Initial packaging for v0.1.10
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccdf988def2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-serverlessrepo
+ pkgdesc = A Python library with convenience helpers for working with the AWS Serverless Application Repository.
+ pkgver = 0.1.10
+ pkgrel = 1
+ url = https://github.com/awslabs/aws-serverlessrepo-python
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-yaml
+ depends = python-boto3
+ depends = python-six
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/s/serverlessrepo/serverlessrepo-0.1.10.tar.gz
+ sha256sums = 671f48038123f121437b717ed51f253a55775590f00fbab6fbc6a01f8d05c017
+
+pkgname = python-serverlessrepo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa61ef7a1427
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mike Javorski (javmorin) <mike.javorski gmail com>
+pkgname=python-serverlessrepo
+_name=${pkgname#python-}
+pkgver=0.1.10
+pkgrel=1
+pkgdesc='A Python library with convenience helpers for working with the AWS Serverless Application Repository.'
+arch=('any')
+url="https://github.com/awslabs/aws-serverlessrepo-python"
+license=('Apache')
+depends=('python-yaml' 'python-boto3' 'python-six')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('671f48038123f121437b717ed51f253a55775590f00fbab6fbc6a01f8d05c017')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+
+ # setup is current configured set to install tests, so remove them beforehand
+ rm -fr tests
+
+ /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1
+}