summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2016-06-28 01:42:18 +0200
committerSven-Hendrik Haase2016-06-28 01:42:18 +0200
commit35745aa91dce33a84b63577a22ee0840d80ef0f0 (patch)
tree616ba6726c39fc14c4bd530036bacaee2f4e0b93
downloadaur-35745aa91dce33a84b63577a22ee0840d80ef0f0.tar.gz
Push python-setoptconf
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b52c202b1f62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-setoptconf
+ pkgdesc = A library that can be used to retrieve program settings from a variety of sources
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/jayclassless/setoptconf
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/jayclassless/setoptconf/archive/0.2.0.tar.gz
+ md5sums = f2a056f7546c9b3a8e0ff6f6e688065d
+
+pkgname = python-setoptconf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a5949dacd2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+_pkgname=setoptconf
+pkgname=python-setoptconf
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A library that can be used to retrieve program settings from a variety of sources"
+arch=('any')
+url="https://github.com/jayclassless/setoptconf"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=(https://github.com/jayclassless/setoptconf/archive/${pkgver}.tar.gz)
+md5sums=('f2a056f7546c9b3a8e0ff6f6e688065d')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}
+# vim:set ts=2 sw=2 et: