summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-12-17 16:22:37 -0500
committerGuillaume Horel2021-12-17 16:22:37 -0500
commit8629e26f821bfbaefd18cfe80dc727517034b5a5 (patch)
tree7eced7fbc20882ba1a62283abfc380fd7e118f9c
downloadaur-8629e26f821bfbaefd18cfe80dc727517034b5a5.tar.gz
initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc17340ace0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-setupmeta
+ pkgdesc = Simplify your setup.py
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = https://github.com/codrsquad/setupmeta
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/setupmeta/setupmeta-3.3.0.tar.gz
+ sha256sums = 32914af4eeffb8bf1bd45057254d9dff4d16cb7ae857141e07698f7ac19dc960
+
+pkgname = python-setupmeta
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4be9caf09d33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname='python-setupmeta'
+_pkgname='setupmeta'
+pkgver='3.3.0'
+pkgrel=1
+pkgdesc="Simplify your setup.py"
+url="https://github.com/codrsquad/setupmeta"
+depends=('python')
+#checkdepends=('python-pep440' 'python-pytest')
+optdepends=()
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('32914af4eeffb8bf1bd45057254d9dff4d16cb7ae857141e07698f7ac19dc960')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}
+
+#check() {
+ #cd "${_pkgname}-${pkgver}"
+ #PYTHONPATH=. pytest tests
+#}