summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2019-08-30 17:42:26 +0200
committerDario Ostuni2019-08-30 17:42:26 +0200
commitb3fd50aef1886ac884459a4e56ee174aa810c250 (patch)
tree4489bd02c718b40d96d8b9db22b870f70add396c
parent8d42fc37b6207b4aaa50300fe762d1f04a3646b3 (diff)
downloadaur-b3fd50aef1886ac884459a4e56ee174aa810c250.tar.gz
Update to version 0.10.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f73e530c961c..6b7fda55ceea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-setuptools-rust
pkgdesc = Compile and distribute Python extensions written in rust as easily as if they were written in C.
- pkgver = 0.10.5
+ pkgver = 0.10.6
pkgrel = 1
url = https://github.com/PyO3/setuptools-rust
arch = any
license = MIT
- makedepends = python-setuptools
depends = python
depends = python-setuptools
depends = python-semantic-version
- source = python-setuptools-rust-0.10.5.tar.gz::https://github.com/PyO3/setuptools-rust/archive/v0.10.5.tar.gz
- sha512sums = a6514c316dfb83f857488740f588803f76fd6984bdf56efb621f635e8342a57c05a12db0f0a20df6f597eedce1619c13fc34ff83a33110136bcad18b4214f64a
+ depends = python-toml
+ source = python-setuptools-rust-0.10.6.tar.gz::https://github.com/PyO3/setuptools-rust/archive/v0.10.6.tar.gz
+ sha384sums = f9c2f7b86c5b88abdf6bd162f2d80029639d0000744a6d830b3a7c63ad54f2571c70a95902b56abef1db390b3f24203f
pkgname = python-setuptools-rust
diff --git a/PKGBUILD b/PKGBUILD
index 443a9c6a4298..ee1b0ef3aa17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
-# Maintainer: Clayton Craft <clayton at craftyguy dot net>
+# Maintainer: Dario Ostuni <dario.ostuni@gmail.com>
+# Contributor: Clayton Craft <clayton at craftyguy dot net>
pkgname=python-setuptools-rust
-pkgver=0.10.5
+pkgver=0.10.6
pkgrel=1
pkgdesc="Compile and distribute Python extensions written in rust as easily as if they were written in C."
arch=('any')
license=('MIT')
url="https://github.com/PyO3/setuptools-rust"
-depends=('python' 'python-setuptools' 'python-semantic-version')
-makedepends=('python-setuptools')
-
+depends=('python' 'python-setuptools' 'python-semantic-version' 'python-toml')
source=("$pkgname-$pkgver.tar.gz::https://github.com/PyO3/setuptools-rust/archive/v$pkgver.tar.gz")
-sha512sums=('a6514c316dfb83f857488740f588803f76fd6984bdf56efb621f635e8342a57c05a12db0f0a20df6f597eedce1619c13fc34ff83a33110136bcad18b4214f64a')
+sha384sums=('f9c2f7b86c5b88abdf6bd162f2d80029639d0000744a6d830b3a7c63ad54f2571c70a95902b56abef1db390b3f24203f')
package() {
cd setuptools-rust-"$pkgver"