summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodedust2021-01-16 23:34:55 +0100
committercodedust2021-01-16 23:34:55 +0100
commitbddbe02e427a2083ccc19fc72c06accd1d0c6c17 (patch)
treeb69d7ac21eb5ec4371c3154379ca3dab26224280
parentb3fd50aef1886ac884459a4e56ee174aa810c250 (diff)
downloadaur-bddbe02e427a2083ccc19fc72c06accd1d0c6c17.tar.gz
Bump version to 0.11.6, get sources via git instead tarball
Downloading sources via git instead of GitHub's tarball to fix the following error: ``` LookupError: setuptools-scm was unable to detect version for 'python-setuptools-rust/src/setuptools-rust-0.11.6'. Make sure you're either building from a fully intact git repository or PyPI tarballs. Most other sources (such as GitHub's tarballs, a git checkout without the .git folder) don't contain the necessary metadata and will not work. For example, if you're using pip, instead of https://github.com/user/proj/archive/master.zip use git+https://github.com/user/proj.git#egg=proj ```
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee1b0ef3aa17..5544d684031c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: Clayton Craft <clayton at craftyguy dot net>
pkgname=python-setuptools-rust
-pkgver=0.10.6
+pkgver=0.11.6
pkgrel=1
pkgdesc="Compile and distribute Python extensions written in rust as easily as if they were written in C."
arch=('any')
license=('MIT')
url="https://github.com/PyO3/setuptools-rust"
depends=('python' 'python-setuptools' 'python-semantic-version' 'python-toml')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/PyO3/setuptools-rust/archive/v$pkgver.tar.gz")
-sha384sums=('f9c2f7b86c5b88abdf6bd162f2d80029639d0000744a6d830b3a7c63ad54f2571c70a95902b56abef1db390b3f24203f')
+source=("$pkgname::git+https://github.com/PyO3/setuptools-rust.git#tag=v$pkgver")
+sha256sums=('SKIP')
package() {
- cd setuptools-rust-"$pkgver"
+ cd "$pkgname"
python setup.py install --root="$pkgdir" --optimize=1
}