summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClayton Craft2018-09-06 18:36:32 -0700
committerClayton Craft2018-09-06 18:36:32 -0700
commite11e83558f6903157c2e2b13c3f86bbeeeaadc56 (patch)
tree3e0d2c76c35e59cb99432d8a6cd40a0ba1f76ce8
downloadaur-e11e83558f6903157c2e2b13c3f86bbeeeaadc56.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7adab101c74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-setuptools-rust
+ pkgdesc = Sampling profiler for Python programs
+ pkgver = 0.10.3
+ pkgrel = 1
+ url = https://github.com/benfred/py-spy
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-setuptools
+ depends = python-semantic-version
+ source = python-setuptools-rust-0.10.3.tar.gz::https://github.com/PyO3/setuptools-rust/archive/v0.10.3.tar.gz
+ sha512sums = cb540ff97034a01f14739953eb9174ffc865f4e64589839dad2576f536e36aecfad3464aa9d53cb9db72406d30649b246af6c89b96dc4e9d04fd444490212941
+
+pkgname = python-setuptools-rust
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bda3ac54db5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Clayton Craft <clayton at craftyguy dot net>
+
+pkgname=python-setuptools-rust
+pkgver=0.10.3
+pkgrel=1
+pkgdesc="Sampling profiler for Python programs"
+arch=('any')
+license=('MIT')
+url="https://github.com/benfred/py-spy"
+depends=('python' 'python-setuptools' 'python-semantic-version')
+makedepends=('python-setuptools')
+
+source=("$pkgname-$pkgver.tar.gz::https://github.com/PyO3/setuptools-rust/archive/v$pkgver.tar.gz")
+sha512sums=('cb540ff97034a01f14739953eb9174ffc865f4e64589839dad2576f536e36aecfad3464aa9d53cb9db72406d30649b246af6c89b96dc4e9d04fd444490212941')
+
+package() {
+ cd setuptools-rust-"$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}