summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaron de Leeuw2013-10-20 11:22:30 +0300
committerYaron de Leeuw2013-10-20 11:22:30 +0300
commitcd8be25eab7b1606fe389780f7c88ea8fe3b4861 (patch)
tree837459564bf90356a8979cd490e9656c145d4fd7
downloadaur-cd8be25eab7b1606fe389780f7c88ea8fe3b4861.tar.gz
adopted python-setuptools_git
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ebe9f0a0c90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-setuptools_git
+ pkgdesc = Setuptools revision control system plugin for Git
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/setuptools-git
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-setuptools
+ depends = git
+ source = http://pypi.python.org/packages/source/s/setuptools-git/setuptools-git-1.0.tar.gz
+ md5sums = de63b541a10c2b83caa478c687458b16
+
+pkgname = python-setuptools_git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..341f7f550070
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintained at : https://github.com/jarondl/aur-pkgbuilds-jarondl
+
+# Maintainer: Yaron de Leeuw <jdlmail at gmail >
+# Contributor: Bruno Carlin <self at aerdhyl dot eu>
+
+pkgname=python-setuptools_git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Setuptools revision control system plugin for Git"
+arch=(any)
+url="http://pypi.python.org/pypi/setuptools-git"
+license=('BSD')
+depends=('python' 'python-setuptools' 'git')
+source=("http://pypi.python.org/packages/source/s/setuptools-git/setuptools-git-$pkgver.tar.gz")
+md5sums=('de63b541a10c2b83caa478c687458b16')
+
+package() {
+ cd $srcdir/setuptools-git-$pkgver
+ python setup.py install --root=$pkgdir/ --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+