summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2015-07-07 20:18:14 +0300
committerIvan Shapovalov2015-07-07 20:18:14 +0300
commita127e6afc0907eb5d8064a4bcf62c9e6f65a0274 (patch)
tree464e42f893bc771c827e5c8888d2dead686c4e51
downloadaur-a127e6afc0907eb5d8064a4bcf62c9e6f65a0274.tar.gz
Automated: initialized with version 0.5.12-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..201d9bbae9bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-setuptools_trial
+ pkgdesc = Setuptools plugin that makes unit tests execute with trial instead of pyunit
+ pkgver = 0.5.12
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/setuptools_trial
+ arch = any
+ license = SPL
+ makedepends = python2-setuptools
+ makedepends = python2-twisted
+ source = http://pypi.python.org/packages/source/s/setuptools_trial/setuptools_trial-0.5.12.tar.gz
+ md5sums = f16f4237c9ee483a0cd13208849d96ad
+
+pkgname = python2-setuptools_trial
+ depends = python2
+ depends = python2-twisted
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd395eb12cab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ivan Shapovalov <intelfx100@gmail.com>
+
+pkgbase=python-setuptools_trial
+pkgname=('python2-setuptools_trial')
+pkgver=0.5.12
+pkgrel=1
+pkgdesc="Setuptools plugin that makes unit tests execute with trial instead of pyunit"
+arch=('any')
+license=('SPL')
+url="http://pypi.python.org/pypi/setuptools_trial"
+makedepends=('python2-setuptools' 'python2-twisted')
+source=("http://pypi.python.org/packages/source/s/setuptools_trial/setuptools_trial-${pkgver}.tar.gz")
+md5sums=('f16f4237c9ee483a0cd13208849d96ad')
+
+build() {
+ cd "${srcdir}/setuptools_trial-${pkgver}"
+ python2 setup.py build
+}
+
+package_python2-setuptools_trial() {
+ depends=('python2' 'python2-twisted')
+
+ cd "${srcdir}/setuptools_trial-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 COPYING.SPL.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.SPL.txt"
+}
+
+# vim: set ts=4 sw=4 tw=0 ft=sh :