summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTetsumi2015-09-18 21:10:28 +0200
committerTetsumi2015-09-18 21:10:28 +0200
commit08b4d9ff9a2833fbd41e9224b88b3e923932a482 (patch)
tree89baf7acfced1c2a0663fecb69d11ae6bcf5d3ed
downloadaur-python-sfml-git.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c567b26c9a56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-sfml-git
+ pkgdesc = The unofficial Python binding for SFML
+ pkgver = 20150820
+ pkgrel = 1
+ url = http://python-sfml.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cython
+ makedepends = git
+ depends = sfml
+ depends = python
+ provides = python-sfml
+ conflicts = python-sfml2-git
+ conflicts = python-sfml
+
+pkgname = python-sfml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..220091ce6c27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Tetsumi <tetsumi@vmail.me>
+# Contributor: Edwin Marshall <emarshall85@gmail.com>
+
+pkgname=python-sfml-git
+pkgver=20150820
+pkgrel=1
+pkgdesc="The unofficial Python binding for SFML"
+arch=('i686' 'x86_64')
+url="http://python-sfml.org"
+license=('LGPL')
+depends=('sfml' 'python')
+conflicts=('python-sfml2-git' 'python-sfml')
+provides=('python-sfml')
+makedepends=('cython' 'git')
+source=()
+md5sums=()
+_gitroot='https://github.com/Sonkun/python-sfml.git'
+_gitname='python-sfml'
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ python setup.py build_ext
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ python setup.py install --root="${pkgdir}" --prefix=/usr
+
+ # Copying the License file
+ install -D -m644 "$srcdir/$_gitname-build/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}