summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Hirzel2022-11-11 13:11:26 -0500
committerAlex Hirzel2022-11-11 13:11:26 -0500
commit4a79180fc1b56cf9e69534d2a6f187d2ecb3d884 (patch)
tree76fb543696a53b13736ff563ac015773e29733fb
parent61240ed3f915d3f745215622380c3dd6d259f02e (diff)
downloadaur-4a79180fc1b56cf9e69534d2a6f187d2ecb3d884.tar.gz
fix license and dependency list per namcap warnings, bump pkgrel
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55ddd53456f6..302cf8a0e14b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-sgp4
pkgdesc = Track earth satellite TLE orbits using up-to-date 2010 version of SGP4
pkgver = 2.21
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.org/project/sgp4/
arch = x86_64
license = MIT
makedepends = python-setuptools
- depends = python
+ depends = python-numpy
source = https://files.pythonhosted.org/packages/source/s/sgp4/sgp4-2.21.tar.gz
sha256sums = 6179b875044877e941633c20af7722fd231a88d8a89af01bf30bd64f33cdecef
pkgname = python-sgp4
- depends = python
+ depends = python-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 8fd4d3343cfb..4d480b461a9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgname='python-sgp4'
_name=${pkgname#python-}
pkgver='2.21'
-pkgrel=1
+pkgrel=2
pkgdesc="Track earth satellite TLE orbits using up-to-date 2010 version of SGP4"
url="https://pypi.org/project/sgp4/"
-depends=('python')
+depends=('python-numpy')
makedepends=('python-setuptools')
license=('MIT')
arch=('x86_64')
@@ -21,8 +21,7 @@ build() {
package() {
depends+=()
cd "${srcdir}/${_name}-${pkgver}"
- # waiting for: https://github.com/brandon-rhodes/python-sgp4/issues/74
- #install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}