summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvantu5z2021-01-14 15:06:38 +0300
committervantu5z2021-01-14 15:06:38 +0300
commit76fe13c04eb8c8f9ed133104827838700f07a6a3 (patch)
treec295bf8b32e9ed51700883d9245292cf02c5f98e
downloadaur-76fe13c04eb8c8f9ed133104827838700f07a6a3.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b638dbc90c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-shell
+ pkgdesc = Python Shell Wrapper Library. A better way to run shell commands in Python.
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/bart-tools/python-shell
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-six
+ source = https://github.com/bart-tools/python-shell/archive/stable/1.0.4.tar.gz
+ sha256sums = a3e35889d44c0d3c8f52b07f0969560e985605e1f66161535e6ca548580d183c
+
+pkgname = python-shell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d08e9430aab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: vantu5z <vantu5z@mail.ru>
+
+pkgname=python-shell
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Python Shell Wrapper Library. A better way to run shell commands in Python."
+url="https://github.com/bart-tools/python-shell"
+depends=('python' 'python-six')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://github.com/bart-tools/python-shell/archive/stable/$pkgver.tar.gz")
+sha256sums=('a3e35889d44c0d3c8f52b07f0969560e985605e1f66161535e6ca548580d183c')
+
+build() {
+ cd "${srcdir}/${pkgname}-stable-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-stable-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}