summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-02-05 22:22:15 +0800
committerUniversebenzene2018-02-05 22:22:15 +0800
commite09918032e9da1eda835357ec0bd4145d152fa08 (patch)
treedad2fae2cdb64b192b9905502263df21afe6f36c
downloadaur-e09918032e9da1eda835357ec0bd4145d152fa08.tar.gz
Initial import 4.9.1
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD35
-rw-r--r--python-sherpa.install3
-rw-r--r--sherpa_local_fftw.patch22
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0afa25a9003e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Mon Feb 5 14:19:04 UTC 2018
+pkgbase = python-sherpa
+ pkgdesc = Modeling and fitting package for scientific data analysis
+ pkgver = 4.9.1
+ pkgrel = 1
+ url = http://cxc.cfa.harvard.edu/contrib/sherpa/
+ install = python-sherpa.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python-setuptools
+ makedepends = gcc-fortran
+ depends = python>=3.5
+ depends = python-numpy
+ depends = fftw
+ optdepends = python-matplotlib: Graphical output
+ optdepends = python-astropy: Data I/O support
+ optdepends = ds9-bin: Imaging requires
+ optdepends = xpa: Imaging requires
+ optdepends = python-pytest>=3.3: For testing suite
+ optdepends = python-mock: For testing suite
+ optdepends = python-pytest-xvfb: For testing suite
+ source = https://files.pythonhosted.org/packages/source/s/sherpa/sherpa-4.9.1.tar.gz
+ source = sherpa_local_fftw.patch
+ md5sums = bc86d545e5d7764b1601e7fe0d8e76a6
+ md5sums = d1823cc7683442d92450fadff7aed362
+
+pkgname = python-sherpa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cddbe9e2c349
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-sherpa
+pkgver=4.9.1
+pkgrel=1
+pkgdesc="Modeling and fitting package for scientific data analysis"
+arch=('i686' 'x86_64')
+url="http://cxc.cfa.harvard.edu/contrib/sherpa/"
+license=('GPL')
+depends=('python>=3.5' 'python-numpy' 'fftw')
+makedepends=('python-setuptools' 'gcc-fortran')
+optdepends=('python-matplotlib: Graphical output'
+ 'python-astropy: Data I/O support'
+ 'ds9-bin: Imaging requires'
+ 'xpa: Imaging requires'
+ 'python-pytest>=3.3: For testing suite'
+ 'python-mock: For testing suite'
+ 'python-pytest-xvfb: For testing suite')
+install=python-sherpa.install
+source=("https://files.pythonhosted.org/packages/source/s/sherpa/sherpa-${pkgver}.tar.gz"
+ 'sherpa_local_fftw.patch')
+md5sums=('bc86d545e5d7764b1601e7fe0d8e76a6'
+ 'd1823cc7683442d92450fadff7aed362')
+
+prepare() {
+ cd "${srcdir}/sherpa-${pkgver}"
+ patch -Np1 -i "${srcdir}/sherpa_local_fftw.patch"
+}
+
+package() {
+ unset LDFLAGS
+ cd ${srcdir}/sherpa-${pkgver}
+
+ install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
diff --git a/python-sherpa.install b/python-sherpa.install
new file mode 100644
index 000000000000..085506bfb8f4
--- /dev/null
+++ b/python-sherpa.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "This package is built with system fftw library. Other things are in default mode. If you want more custom build mode, you can follow the link below and modify the setup.cfg or create a patch yourself: https://github.com/sherpa/sherpa#custom-source-build"
+}
diff --git a/sherpa_local_fftw.patch b/sherpa_local_fftw.patch
new file mode 100644
index 000000000000..be62247ab32c
--- /dev/null
+++ b/sherpa_local_fftw.patch
@@ -0,0 +1,22 @@
+--- a/setup.cfg 2017-08-03 21:50:56.000000000 +0800
++++ b/setup.cfg 2018-02-05 16:36:19.685492797 +0800
+@@ -31,15 +31,15 @@
+
+ # FFTW Library
+ # Uncomment to use a local installation
+-#fftw=local
++fftw=local
+
+ # If fftw=local uncomment the following lines and
+ # change the default location of libraries and the name
+ # of the library to be linked (usually fftw3)
+ # (include multiple values by separating them with spaces)
+-#fftw-include_dirs=build/include
+-#fftw-lib-dirs=build/lib
+-#fftw-libraries=fftw3
++fftw-include_dirs=/usr/include
++fftw-lib-dirs=/usr/lib
++fftw-libraries=fftw3
+
+ # Region Library
+ # Uncomment to use a local installation