summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavol Kapusta2017-09-20 16:57:48 +0200
committerPavol Kapusta2017-09-20 16:57:48 +0200
commit77e1d37c61d68ea0aff6e6eceb7eeaf135f1c064 (patch)
tree5730e341f86c2a731abe91eea7690d2b5e01579f
downloadaur-77e1d37c61d68ea0aff6e6eceb7eeaf135f1c064.tar.gz
first commit of AUR package python-shisensho
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rwxr-xr-xpyshisensho3
-rw-r--r--python-shisensho.patch32
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6354bfd26dc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-shisensho
+ pkgdesc = Shisen-Sho game
+ pkgver = 0.9.12
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/shisensho
+ arch = any
+ license = ALv2
+ makedepends = python-setuptools
+ depends = python
+ depends = tk
+ depends = python-pillow
+ source = https://pypi.io/packages/source/s/shisensho/shisensho-0.9.12.tar.gz
+ source = python-shisensho.patch
+ source = pyshisensho
+ sha256sums = 5957749c0342976b2465329e01820f537b4239d7885cd33ccef9fdd19639105a
+ sha256sums = c6d14c1b24cc431033a20c2fca1139647fcd920900500184b71670a86f2b271b
+ sha256sums = 182448dc0e688589f1176fe4444a551df79519382832c0153a1e3a41b9c75f8b
+
+pkgname = python-shisensho
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b171c6aafb80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Pavol Kapusta <pavol.kapusta at gmail dot com>
+
+_pkgname='shisensho'
+pkgname="python-${_pkgname}"
+pkgver=0.9.12
+pkgrel=1
+pkgdesc='Shisen-Sho game'
+arch=('any')
+url='https://pypi.python.org/pypi/shisensho'
+license=('ALv2')
+depends=('python' 'tk' 'python-pillow')
+makedepends=('python-setuptools')
+source=("https://pypi.io/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz" "python-shisensho.patch" "pyshisensho")
+sha256sums=('5957749c0342976b2465329e01820f537b4239d7885cd33ccef9fdd19639105a'
+ 'c6d14c1b24cc431033a20c2fca1139647fcd920900500184b71670a86f2b271b'
+ '182448dc0e688589f1176fe4444a551df79519382832c0153a1e3a41b9c75f8b')
+
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p3 -i "$srcdir/python-shisensho.patch"
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py check
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root "${pkgdir}"
+ mkdir "$pkgdir/usr/bin"
+ cp -p "$srcdir/pyshisensho" "$pkgdir/usr/bin/"
+}
diff --git a/pyshisensho b/pyshisensho
new file mode 100755
index 000000000000..398ed46a6e07
--- /dev/null
+++ b/pyshisensho
@@ -0,0 +1,3 @@
+#!/bin/bash
+python /usr/lib/python3.6/site-packages/shisensho/shisensho.py
+
diff --git a/python-shisensho.patch b/python-shisensho.patch
new file mode 100644
index 000000000000..50b266884620
--- /dev/null
+++ b/python-shisensho.patch
@@ -0,0 +1,32 @@
+diff -ura python-shisensho_orig/src/shisensho-0.9.12/shisensho/data/config.json python-shisensho/src/shisensho-0.9.12/shisensho/data/config.json
+--- python-shisensho_orig/src/shisensho-0.9.12/shisensho/data/config.json 2017-01-20 05:29:09.000000000 +0100
++++ python-shisensho/src/shisensho-0.9.12/shisensho/data/config.json 2017-09-20 13:18:30.121384165 +0200
+@@ -12,7 +12,7 @@
+ ,"background-file" : "data/wallpapers/wallpaper1.jpg"
+ ,"tiles-file" : "data/tilescolor3.png"
+ ,"logfile" : false
+- ,"initial-dim" : [14,6]
++ ,"initial-dim" : [18,10]
+ ,"delay-deleting" : 0.3
+ ,"tiles-matrix" : [
+ [
+@@ -72,7 +72,18 @@
+ ]
+ ]
+ , "tiles" :[
+- {
++ {
++ "dim":[18,10],
++ "list" : ["character-1","character-2","character-3","character-4","character-5","character-6",
++ "character-7","character-8","character-9",
++ "bamboo-1","bamboo-2","bamboo-3","bamboo-4","bamboo-5","bamboo-6","bamboo-7",
++ "bamboo-8","bamboo-9",
++ "circle-1","circle-2","circle-3","circle-4","circle-5","circle-6","circle-7",
++ "circle-8","circle-9",
++ "dragon-red","dragon-green","dragon-white"
++ ]
++ }
++ ,{
+ "dim":[14,6],
+ "list" : ["bamboo-1","bamboo-2","bamboo-3","bamboo-4","bamboo-5","bamboo-6","bamboo-7",
+ "bamboo-8","bamboo-9",