summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-11-24 22:24:58 +0300
committerCaleb Maclennan2021-11-24 22:24:58 +0300
commit3591e8dc2230325f1167aa16f514e2c3bd47f853 (patch)
tree904b594ed019e8ade9580b1022dd7176a7d78744
parent0170e2e061826073dee2af66714790211518ffd5 (diff)
downloadaur-3591e8dc2230325f1167aa16f514e2c3bd47f853.tar.gz
upgpkg: python-shortuuid 1.0.0-2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD35
2 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 812a6e03bdc7..02101e362040 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python-shortuuid
- pkgdesc = shortuuid is a simple python library that generates concise, unambiguous, URL-safe UUIDs.
+ pkgdesc = library that generates concise, unambiguous, URL-safe UUIDs
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/skorokithakis/shortuuid
arch = any
- license = custom:BSD
+ license = BSD
+ makedepends = python-setuptools
depends = python
options = !emptydirs
- source = python-shortuuid-1.0.0.tar.gz::https://github.com/skorokithakis/shortuuid/archive/v1.0.0.tar.gz
+ source = shortuuid-1.0.0.tar.gz::https://github.com/skorokithakis/shortuuid/archive/v1.0.0.tar.gz
sha256sums = cc2539aaed1b4de34853ee4aaf8331176b768a2d3a87d5a790453e082ce36850
pkgname = python-shortuuid
diff --git a/PKGBUILD b/PKGBUILD
index ea8ca4f68b75..b2715d731357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,33 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: jnanar <info@agayon.be>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=python-shortuuid
pkgver=1.0.0
-pkgrel=1
-pkgdesc="shortuuid is a simple python library that generates concise, unambiguous, URL-safe UUIDs."
-arch=('any')
-url="https://github.com/skorokithakis/shortuuid"
-license=('custom:BSD')
-depends=('python')
+pkgrel=2
+pkgdesc='library that generates concise, unambiguous, URL-safe UUIDs'
+arch=(any)
+url="https://github.com/skorokithakis/${pkgname#python-}"
+license=(BSD)
+depends=(python)
options=(!emptydirs)
-source=("$pkgname-$pkgver.tar.gz::${url}/archive/v$pkgver.tar.gz")
+makedepends=(python-setuptools)
+_archive="${pkgname#python-}-$pkgver"
+source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('cc2539aaed1b4de34853ee4aaf8331176b768a2d3a87d5a790453e082ce36850')
+build() {
+ cd "$_archive"
+ python setup.py build
+}
+
+check() {
+ cd "$_archive"
+ python setup.py test
+}
+
package() {
- cd ${pkgname#python-}-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING
}