summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-04-02 10:54:50 +0200
committerhaawda2020-04-02 10:54:50 +0200
commitfde27d65a715d2e1ab900730736b5cd6ad7cad54 (patch)
treef11786812f88f263e007d7803e7c8a1df50790eb
downloadaur-fde27d65a715d2e1ab900730736b5cd6ad7cad54.tar.gz
initial upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48ce703cc9f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-shortuuid
+ pkgdesc = shortuuid is a simple python library that generates concise, unambiguous, URL-safe UUIDs.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/skorokithakis/shortuuid
+ arch = any
+ license = BSD
+ depends = python
+ options = !emptydirs
+ source = python-shortuuid-1.0.1.tar.gz::https://github.com/skorokithakis/shortuuid/archive/v1.0.1.tar.gz
+ md5sums = SKIP
+
+pkgname = python-shortuuid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df6345ade5ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: jnanar <info@agayon.be>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=python-shortuuid
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="shortuuid is a simple python library that generates concise, unambiguous, URL-safe UUIDs."
+arch=('any')
+url="https://github.com/skorokithakis/shortuuid"
+license=('BSD')
+depends=('python')
+options=(!emptydirs)
+source=("$pkgname-$pkgver.tar.gz::${url}/archive/v$pkgver.tar.gz")
+md5sums=('SKIP')
+
+package() {
+ cd ${pkgname#python-}-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+}