summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2019-09-28 12:18:16 +0200
committerjnanar2019-09-28 12:18:16 +0200
commit766d81ae5fe47070122deaef9a9cffe39b1bde6f (patch)
treea5966000e7df770b27892cb2729776a50a3987c9
downloadaur-766d81ae5fe47070122deaef9a9cffe39b1bde6f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a7fc1ee39c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-shortuuid-git
+ pkgdesc = shortuuid is a simple python library that generates concise, unambiguous, URL-safe UUIDs.
+ pkgver = v0.5.0.r18.g4da632a
+ pkgrel = 1
+ url = https://github.com/skorokithakis/shortuuid
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ provides = python-shortuuid
+ replaces = python-shortuuid
+ options = !emptydirs
+ source = git+https://github.com/skorokithakis/shortuuid.git
+ md5sums = SKIP
+
+pkgname = python-shortuuid-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c61ea262a87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+#Maintainer: jnanar <info@agayon.be>
+
+pkgname=python-shortuuid-git
+pkgver=v0.5.0.r18.g4da632a
+pkgrel=1
+pkgdesc="shortuuid is a simple python library that generates concise, unambiguous, URL-safe UUIDs."
+arch=(any)
+url="https://github.com/skorokithakis/shortuuid"
+license=('BSD')
+depends=('python')
+makedepends=('git')
+options=(!emptydirs)
+provides=('python-shortuuid')
+replaces=('python-shortuuid')
+#optdepends=('')
+
+source=('git+https://github.com/skorokithakis/shortuuid.git')
+_gitname="shortuuid"
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $_gitname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}