summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanpi2015-10-05 12:10:01 +0200
committerSanpi2015-10-05 12:10:01 +0200
commit609f19eb9b3f9fc56fb9e00243c1afb365b256c7 (patch)
treeb36a74764e9a5b92bf492acf99f967a1706e3e7b
downloadaur-609f19eb9b3f9fc56fb9e00243c1afb365b256c7.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fee055373b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-shyaml
+ pkgdesc = YAML for the command line
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = https://github.com/0k/shyaml
+ arch = x86_64
+ license = BSD
+ depends = python
+ depends = python-yaml
+ source = git+https://github.com/0k/shyaml.git
+ sha256sums = SKIP
+
+pkgname = python-shyaml
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8dda60cc829a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/*.pkg.tar.xz
+/*.tar.gz
+/src
+/shyaml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..364b2729a14b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
+pkgname=python-shyaml
+pkgver=0.3.4
+pkgrel=1
+pkgdesc='YAML for the command line'
+arch=('x86_64')
+url='https://github.com/0k/shyaml'
+license=('BSD')
+depends=('python' 'python-yaml')
+makedepends=()
+source=("git+https://github.com/0k/shyaml.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/shyaml"
+
+ git checkout $pkgver
+}
+
+package() {
+ cd "$srcdir/shyaml"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+}