summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonid Bloch2017-01-04 00:04:08 +0200
committerLeonid Bloch2017-01-04 00:04:08 +0200
commit78a0beb30fb8fb24bb9378c2ce960bd536bf3e28 (patch)
treeaa4666e13d44a2f80ce93d41a58476c7782ed32e
downloadaur-78a0beb30fb8fb24bb9378c2ce960bd536bf3e28.tar.gz
Initial commit
Signed-off-by: Leonid Bloch <leonid.bloch@esrf.fr>
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD29
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..806045e6d1ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-silx
+ pkgdesc = A collection of Python packages for data analysis at synchrotron radiation facilities.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = http://www.silx.org
+ arch = any
+ license = MIT
+ license = LGPL
+ makedepends = git
+ makedepends = cython
+ depends = python-numpy
+ depends = python-pyqt5
+ depends = python-matplotlib
+ optdepends = python-h5py: for HDF5 input/output
+ optdepends = ipython: for interactive console
+ optdepends = python-qtconsole: for GUI console
+ optdepends = python-pyopencl: for sift - OpenCL implementation
+ optdepends = opencl-driver: for sift - OpenCL implementation
+ source = https://github.com/silx-kit/silx/archive/v0.3.0.tar.gz
+ sha1sums = 448d3953e4b35b713570e15c2d785fd8011b0ed1
+
+pkgname = python-silx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc0e8dd19ad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Package maintainer: Leonid B <leonid dot bloch at esrf dot fr>
+# Upstream contact: silx at esrf dot fr
+pkgname=python-silx
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A collection of Python packages for data analysis at synchrotron radiation facilities."
+arch=('any')
+url="http://www.silx.org"
+license=('MIT' 'LGPL')
+depends=('python-numpy' 'python-pyqt5' 'python-matplotlib')
+optdepends=('python-h5py: for HDF5 input/output'
+ 'ipython: for interactive console'
+ 'python-qtconsole: for GUI console'
+ 'python-pyopencl: for sift - OpenCL implementation'
+ 'opencl-driver: for sift - OpenCL implementation')
+makedepends=('git' 'cython')
+source=("https://github.com/silx-kit/${pkgname#*-}/archive/v${pkgver}.tar.gz")
+sha1sums=('448d3953e4b35b713570e15c2d785fd8011b0ed1')
+
+build() {
+ cd "${srcdir}/${pkgname#*-}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname#*-}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -D copyright "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}