summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2021-11-22 18:25:45 -0600
committerAnthony Wang2021-11-22 18:25:45 -0600
commit427ac28636d95f547704a82090876a86ee1e767e (patch)
tree4b16256e1c743d97ed41eae3245a1a840f737970
downloadaur-427ac28636d95f547704a82090876a86ee1e767e.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c94d13a0ec0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-simpervisor
+ pkgdesc = Simple async process supervisor
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/yuvipanda/simpervisor
+ arch = any
+ license = unknown
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/simpervisor/simpervisor-0.4.tar.gz
+ sha256sums = cec79e13cdbd6edb04a5c98c1ff8d4bd9713e706c069226909a1ef0e89d393c5
+
+pkgname = python-simpervisor
+ depends = python
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9316b6cca509
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase='python-simpervisor'
+pkgname=('python-simpervisor')
+_module='simpervisor'
+pkgver='0.4'
+pkgrel=1
+pkgdesc="Simple async process supervisor"
+url="https://github.com/yuvipanda/simpervisor"
+depends=('python')
+makedepends=('python-setuptools')
+license=('unknown')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('cec79e13cdbd6edb04a5c98c1ff8d4bd9713e706c069226909a1ef0e89d393c5')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}