summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2024-03-23 20:01:32 +0100
committerGiovanni Harting2024-03-23 20:01:32 +0100
commit2921063cad514a31ce0d93b022248209ffc1939e (patch)
treeb1853d3c0e8d355a27b5a62eedf757edf2b4ae9a
parent5902326c39896b8cb195e497015b925397a12b09 (diff)
downloadaur-2921063cad514a31ce0d93b022248209ffc1939e.tar.gz
upgpkg: python-simple-pid 1.0.1-2
enable tests; formatting
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1912e9adf3eb..091ec5ea018d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = python-simple-pid
url = https://github.com/m-lundberg/simple-pid
arch = any
license = MIT
+ checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
diff --git a/PKGBUILD b/PKGBUILD
index b24018ff260d..fbaa39ad1d82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@ pkgname=python-simple-pid
_name=${pkgname#python-}
pkgver=1.0.1
pkgrel=2
-pkgdesc="A simple and easy to use PID controller in Python"
+pkgdesc='A simple and easy to use PID controller in Python'
arch=(any)
-url="https://github.com/m-lundberg/simple-pid"
+url='https://github.com/m-lundberg/simple-pid'
license=(MIT)
depends=(python)
makedepends=(python-build python-installer python-wheel python-setuptools)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/m-lundberg/$_name/archive/v$pkgver.tar.gz")
+checkdepends=(python-pytest)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
b2sums=('29e54cc3e6bddd9103979a0ee1acdfb60e3bd85ef199b2a538144ec5e0c8ea45d4ce22615df618fdd920d0c0e04a50a844d598e9fc09c5873bb8d9c550548723')
build() {
@@ -18,6 +19,11 @@ build() {
python -m build --wheel --no-isolation
}
+check() {
+ cd $_name-$pkgver
+ pytest -vv --deselect tests/test_pid.py::test_converge_system
+}
+
package() {
cd $_name-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl