summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2024-01-13 17:45:54 +0100
committerGiovanni Harting2024-01-13 17:45:54 +0100
commit5902326c39896b8cb195e497015b925397a12b09 (patch)
treecf042d7dc1b1c8f9ce627d4b3e1ce3bec3435c4b
parent3f9eec2ed2e8bd925bbfc62135587a6dd002989c (diff)
downloadaur-5902326c39896b8cb195e497015b925397a12b09.tar.gz
upgpkg: python-simple-pid 1.0.1-2
switched to PEP 517
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27e9cd0d5957..1912e9adf3eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = python-simple-pid
pkgdesc = A simple and easy to use PID controller in Python
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/m-lundberg/simple-pid
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
source = python-simple-pid-1.0.1.tar.gz::https://github.com/m-lundberg/simple-pid/archive/v1.0.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 9e478b142872..b24018ff260d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
pkgname=python-simple-pid
_name=${pkgname#python-}
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A simple and easy to use PID controller in Python"
arch=(any)
url="https://github.com/m-lundberg/simple-pid"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-wheel python-setuptools)
source=("$pkgname-$pkgver.tar.gz::https://github.com/m-lundberg/$_name/archive/v$pkgver.tar.gz")
b2sums=('29e54cc3e6bddd9103979a0ee1acdfb60e3bd85ef199b2a538144ec5e0c8ea45d4ce22615df618fdd920d0c0e04a50a844d598e9fc09c5873bb8d9c550548723')
build() {
cd $_name-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $_name-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}