summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIngo Heimbach2020-04-17 14:38:23 +0200
committerIngo Heimbach2020-04-17 14:38:23 +0200
commit1db04423b4dd6285b6f0b5453c9cd6ac58fa4d57 (patch)
tree9c0c1ea31a1be424eff2fbf5409f98ba2c7453bc
downloadaur-1db04423b4dd6285b6f0b5453c9cd6ac58fa4d57.tar.gz
Add a `PKGBUILD` for `simple-term-menu` version v0.4.2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00c10134c56a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-simple-term-menu
+ pkgdesc = A Python package which creates simple interactive menus on the command line.
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://github.com/IngoHeimbach/simple-term-menu
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/IngoHeimbach/simple-term-menu/archive/v0.4.2.tar.gz
+ sha256sums = 3587c136dc633baf4d90a9d093f0ce6473df76132f82db6c35b90093f132a7df
+
+pkgname = python-simple-term-menu
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2003141c0783
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.tar.xz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3666242233e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ingo Heimbach <i.heimbach@fz-juelich.de>
+
+pkgname="python-simple-term-menu"
+pkgver="0.4.2"
+pkgrel="1"
+pkgdesc="A Python package which creates simple interactive menus on the command line."
+arch=("any")
+url="https://github.com/IngoHeimbach/simple-term-menu"
+license=("MIT")
+depends=("python")
+makedepends=("python-setuptools")
+source=("https://github.com/IngoHeimbach/simple-term-menu/archive/v${pkgver}.tar.gz")
+sha256sums=("3587c136dc633baf4d90a9d093f0ce6473df76132f82db6c35b90093f132a7df")
+
+build() {
+ cd "${srcdir}/${pkgname#*-}-${pkgver}" || return
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname#*-}-${pkgver}" || return
+ python setup.py install --optimize=1 \
+ --prefix=/usr \
+ --root="${pkgdir}" \
+ --skip-build
+}